Problems with library NAS after Upgrading to v 2.698

Today I upgraded Volumio to version v 2.698 and now I don’t have a working Connection to the NAS server. I mounted the NAS properly via nfs and Volumio showed that the songs will be added to the library. But neither the view under Sources shows any indexed tracks nor the list under “Library”. On the top I can see the green loading-bar stopping right before it reaches the right side of the screen.
Under “media servers” I can see the Server and can access the different directories albums etc… But if I try to play a song nothing happens.
On the left side at the bottom the “browse”-wheel is rotating so Volumio seems to have access to the server.


  • Raspberry Pi 3 B+
  • Hifiberry DAC +
  • SanDisk micro SD 32GB
  • Volumio v 2.69
  • Synology DS718+

edit: I already did a clean install.

(edit: outdated)
Update: after some more reboots problem is solved.
I have no idea why, but I have no problem anymore.

Update 2:
after an other restart I have the same problems like before.
Even web radio is not working. I click on play, but nothing happens. When I try to update the library, it appears the rotating circle in the middle of the screen and after round about 15 sec I hear this welcome-sound of Volumio, but the library doesn’t get updated.

I seem to be having the same problem after upgrading to 2.698. I first noticed the problem when I tried to go to “Browse -> Music Library” this morning and nothing came up. When I went to check the “Settings -> Sources” screen, I noticed that my NAS showed up as mounted under “Network Drives” but there was nothing showing up under “My Music.” Clicking “Rescan” did nothing, and rebooting didn’t seem to help. Trying to delete the share under “Network Drives” also doesn’t work (I get an error saying “cannot remove share”). I uploaded my logondemand file here: It seems from the log that there is a problem loading mpd. Many thanks for looking into this! Best wishes,


same problem here since the update yesterday.

Can’t listen any music. :frowning:

You could either try to connect to another Wifi or to connect your Raspberry Pi to the Ethernet if possible.
I figured out that everything works fine if I am connected to my 5 GHz Wifi and not to the 2.4GHz, so it seems to be a problem of the network-drivers!?

I don’t know how to configure the raspberry to use 5ghz instead of 2.4.

Did anybody else try this ?

Will it be a fix about this problem ?

Hi there.

I have the same problem over here.

I don’t think however it has anything to do with network connectivity. I can ssh into volumio and cd into my music collection with no problem. I can also cat mp3 files. So, the share (in my case on a synology NAS mounted through cifs) is there and accessible.


I’ve just installed v2.699 : unfortunately, it didn’t fix the problem.
After some reboot, still the same, volumio doesn’t work, it can’t see my nas, neither just playing a radio.

I got this when playing Bruckner… Something going wrong with index…

Verstuurd vanaf mijn SM-G960F met Tapatalk

I have got the same issue that the UI shows a track different to what is played sporadically.
The version is 2.699 and Volumio with Hifiberry DAC+ Pro on my Raspberry 4 (4GB) is playing in random mode from NAS using the ethernet connection.
When I skip to the next track, everything is fine. When I go to the last 100 tracks list and start the wrong shown track in the list, that track is getting played.
So I don’t think it’s the index for the tracks. It looks like the wrong information is shown sometimes in the UI.
This doesn’t happen often, but would be nice if it gets fixed.
But after all: Thank you all for the great music player and all the useful plugins for it!
I enjoy it very much.

I have also problem with the library as well as radio( vers 2.699). Everything is gone and there seems to be no way to play.
It has wifi-connectivity. Luckily I had a SDcard with an older version.

We’ve been at work to understand the root cause of this, see this conversation:

We will release an update to solve this ASAP

Just a quick note to say that today’s release (2.703) has fixed the problem in accessing the NAS library on my end. Many thanks to the developers for all their work on this and for making Volumio such a terrific product.

Best wishes,

With 2.703 probability is reduced. I have a large db. Currently it is ok, but 5 minutes ago I have seen it again.
If I see it, I will post my log.

I can reproduce it now:

  1. Existing playlist
  2. search in the music libaray
  3. Select one entry.
  4. the right entry is played
  5. But the wrong title is displayed (the one from the search -1)

I have a similar problem on 2.713. Fresh installation on Raspbery PI3. No plugins installed.
After adding and mounting a NAS it started to scan for media and stopped after a while.
The library is displayed empty, My music also shows nothing.

Fixed in 2.714