Problem with volume

After 2.692 update I lost volume control. I’ll try to describe what happens. When I turn on Volumio it’s immediately muted, even though my default volume is 20%. I can control volume only through Pi terminal but whenever I try to do it through WEBGUI, the volume in alsamixer resets to zero, and Volumio keeps playing on it’s own default volume.
Raspberry Pi 3B+
IQaudIO Pi-DigiAMP+

I recorded a video (in attachment).

P.S. Croatian translation not updated. Here is new one (8.74 MB)

The same to me.
The hardware mixer is not available in the settings.

If I switch the volume control to software, it works. But you cannot switch back to hardware control.


Hi All,
same to me…

Same problem since the update yesterday to 2.692.
IQaudio DigiAMP+


I had the same problem with 4 updated systems and ask myself if this only appears on updated systems or also on a fresh installation.

Did someone already try ? I will try later and report.

Best Regards

Have the same / similar problem since 2.687, thought the problems was solved with ver 2.691 but some still remains in 2.692

Currently I have 2 RPi 3B with HiFiBerry clone dac (PiFi) installed as HiFiberry Dac + with problems

After update I’m not able to control the volume
Volume options, Mixer control name says “Analouge” and ain’t changeable

If I in Settings, Playback options, Audio output just click save and wait a a couple of seconds , then I’m able to change volume again
But after a reboot the problems are back

Note: also have a Rpi Zero with Phat dac that seemes to work without any problems with 2.692

It seems that it affects only the RPi2 boards.
My Volumio on a RPi3 is functioning without these symptoms.

I will roll-back to the last version and wait until after the holidays.

Not true, i have RPI3 boards. :wink:

This is weird:

  • the RPI2 with IQAudio Dac+ (I2S) and Amp+ has all the problems detected by you.
  • the RPi3 with an USB DAC (Creative Soundblaster Play) works fine and has not any problems. My son is using it right now and I hear no complaints.

For the RPi2 with the IQAudio DAC+ I just flashed the SD Card with a previous version of Volumio. The setup is ongoing.

I personally do not think that the Volumio developers are really in the mood for a bug hunt during the Christmas holidays.
Everybody deserves a little bit of relaxation, beloved family around and some nice wine while listening in endless loop “Last Christmas” or “Feliz Navidad” :smiley: .
I personally do not want to open any work emails until I am really back to work.

I hope the Volumio guys use the same mental stress hygiene behavior - we are all human beings.

For the ones of us not willing to wait I found some links to previous versions and posted in the “Roll-back” post.


Why is this weird?
Seems like there is a problem with i2s. :wink:

It’s the same, I tried.

came here to post this. Extremely frustrating. My Pi3s+Volumio are currently unusable. Was this release even tested?

This temporary fix the problem for me

Playback options,
Audio output and just click save and wait a a couple of seconds (until I see the splash), then I’m able to change volume again
But after a reboot the problems are back
Player restarted.jpg

I know. The only fast solution was the roll-back. The set-up is not complete because I lost my collection of web radios and podcasts. The last version is at least functioning.

Hey, it’s Christmas! - I try to take it easy.
I personally enjoyed a glass of wine and accepted this situation.

You are definitely not the only one.

If it really burns and no Volumio bug-fix is coming until start of January 2020, you can get some USB DAC and survive until the rescue is there.
Buy something cheap or if you have the possibility get a Chord Mojo.

Regards from Munich,

PS: as a lesson for us all, I will keep at least some Volumio versions for “bad” days. A functioning old version is better than an update into nirvana.

It is not the first time that this happen. :confused:
I have a lot of this devices in my house, and it is very frustrating. This time i had “luck” because i updated “only” 4 of my devices.
The problem is that my devices are not reachable, they are in the furniture. So an easy restore is not possible. :unamused:
You can easy transfare your data from one to another volumio.
Copy this files:
Webradio: /data/favourites/my-web-radio
Networkshares: /data/configuration/system_controller/networkfs/config.json
Playlist: /data/playlist

My wish is something like a backup/restore function.
Or an easy way to rollback to previous (working) version without touching the SD-Card.

Even though it does not cover a system rollback, maybe have a look at the plugin “Backup & Restore Data” (

It is available for installation from the plugin store. You find it in the section “System Tools”.

Haha! :smiley: Thanks for your perspective, Adrian. I did indeed enjoy an adult beverage or two in the awkward silence produced by a lack of music in my kitchen. I especially liked the Chord Mojo suggestion. I’ll just nip down to the corner store and pick one up.

I will try out SonosKiller’s suggestion of saving audio settings as a work-around until the fix comes out.

Happy holidays for those that have them. Much love to the Volumio team for doing what they do. :heart:

Wish I had seen this before I did an upgrade to 2.692. See also my entry in “help” section.
Confirm problem is with IQAudio DAC.

Hi friends,

I tested now - as already reported in another thread it doesn’t depend on OTA or fresh install and:
It also doesn’t depend on the model of PI (2,3,3+) nor on the model of (i2s) DAC.

The issue is easily reproducable - tested with the following I2S DACs:

TerraBerry DAC 2
Allo Boss (old versions + 1 newest version including Allo Isolator)
Allo Piano 2.1 with KALI Reclocker (4 pcs)
MamboBerryDAC+ with KALI Reclocker
OSA DACBerry Pro (will get the “+ pro” soon)
HifiBerry + Pro (5 pcs) ; HifiBerry ADC ; HifiBerry Digi Pro +
Nanomesher DAC 1 pro (2 pcs)
IQaudio + (have plenty of these for standard tests)
IQaudio + pro
Generic ES9023 DAC
AOIDE DAC ES9018 (unsupported with self hacked driver and DAC model installation ) (5 pcs)
Audiophonics ES9038Q2M micro USB edition (unsupported with self hacked DAC model integration)
some other unsupported “non hat” i2s DACs from China (not happy with these for now - maybe i’m doing something wrong)

All these configurations didn’t show this issue to at least v2.657 and i id not notice these issues up to 2.668.
Beginning with v2.671 (same kernel version 4.19.73) things went wierd on some configs… and now v2.692 (kernel v4.19.83) on all of them. It even “seems” that upgraded installs sometimes worked more reliable than fresh v2.692 installations - but not sure…
USB DACs do not seem to be affected at all. I only own 3 different models to test with, but others here on the forum also reported there is no issue with USB DACs.

I’m sure there soon will be a fix from Volumio team early january after the public holidays.
So long - let’s use older versions or temporarily switch to USB…
Merry christmas and a happy new year.

Best Regards

Thanks for the tip.
That works here as well, it will do for the time being.
(Pi3B+ and HifiBerry DAC Plus)