Problem with audio from analog input

Hello everyone.
I’ve installed Volumio Premium on my RPi 5 together with a Hifime UR23 SPDIF Optical to USB converter to get audio from my Chromecast Audio out to my USB DAC. Volumio correctly identifies the existence of the USB input device and allows me to select it, which is great. The problem is that the audio coming through is unlistenable (intermittent cut-outs, clicks, etc…).
I checked that the connection is clean and tight on both ends, so that shouldn’t be the cause. I also went through every menu I could find in Volumio but there doesn’t seem to be anything I can configure.
Does anybody have ideas on what I could try to troubleshoot the issue? Could it be due to the asynchronous transmission of data through USB? Would really like to get this working so that I can switch input sources directly through Volumio without having to physically walk to the DAC to select another input.

1 Like

it could well be a problem with the SPDIF cable

what kind of cable are you using? is it a cable specifically designed for SPDIF digital signals, or is it a general-purpose RCA cable?

It’s an optical cable that I currently use to connect the CCA directly to the DAC and it works perfectly. I will try another cable I have laying around, just to be sure.

Just tried a different, brand new optical cable. Same issue…

You have set the same bit rate on both your DAC and this input?
so as example: both to 16bit 44.1kHz

I have no idea how to configure this on the input…
The Chromecast doesn’t have any settings that I can play with either…
I’m convinced the issue is due to sampling rate mismatch buy have no idea how to tackle it.
The DAC will play anything (topping E30).

Suitable for transferring DAT tapes, minidiscs or other digital sources to audio files on your computer. Please note that it cannot be connected directly to a USB device such as a DAC, it must be connected to a USB host such as a computer.
Hifime UR23

1 Like

I think that’s your problem.
This is actually a windows device and most likely windows will give you the option to configure it.
Linux does recognize it, but lacks this option.
In order to make it work both Source and Receiver must be in sync on the bits.

So to be honest, I don’t think this will work well together.

Thanks guys.
I was hoping this would work, but apparently not.
Any ideas on how to get an optical input into the Pi to use it as an additional input that Volumio can route to the USB output?

Something like this:

I Will give it a try and report back.

Just to be sure, I haven’t test this myself. but some precautions, you might run into the same problem:

Yeah mate, don’t worry, I won’t hold you accountable. :wink:
Based on the their website, it seems that the Digi+ DSP version would be better since it can manage different inbound sample rates, which the version you posted cannot. Since the CCA streams what it receives without any SRC going on (as far as I know), I need to have some flexibility to account for this.
I’ll order one and give it a try.
Fingers crossed!