Problem mounting fritzbox nas

I have a problem mounting the external HDD USB 3.0 connected to fritz box 7490 with volumio.
Path: write down the whole path as it shows in windows explorer?
File share type:cifs
Username: ?
Password: ?
Options: ver=1.0

Any help ?

Have you searched the forums? There are a number of posts that I remember with problems with Fritzboxes.

yes but since the recent update of volumio none of the answers solved the problem

Do you know how to solve it?

You have to create a special user and password in the Fritz!OS for the SMB access. Try to mount it from your PC with this credentials. If this will work, it should also work with Volumio.

BTW: The latest FRITZ!OS version 07.20 (from July 2020) is disabling SMBv1 (vers=1.0) for security reasons. If you still need it, you have manually enable it in the Fritz!OS settings or better set now “vers=3.0” to your SMB options of Volumio

I can explore HDD via pc and media server of volumio but I can not mount it via network drive of volumio.
If I disable SMB from fritz box settings then I do not have to enter vers=3.0 on volumio.
What I have to enter as path on volumio settings?

My settings are as follows (adapt to your setup):


Path: FRITZ.NAS/MP3/Musik
File share type: cifs
Username: enter your username for NAS access of the Fritzbox
Password: your password for the Fritz NAS user
Options: vers=3.0 (only for the newest Fritz!OS. For older version you have to use vers=1.0)

My MP3 collection is connected to a USB stick on the Fritz!Box

Success!! Thank you very much for your help. If anyone uses Fritz Box this icon is what he/she has to copy in order to mount via NAS the external HDD

1 Like


I am a new user to Volumio. It’s a real nice program. Now i want to connect my USB connected hardrive to the Fritz!Box 5490.

First of all i thought that should be easy. But it’s NOT.

I followed the Fritz instructions to share a harddrive:

I also read a lot of topics with problems connecting a Fritz!box. Great support from you guys, but i can not get trough.

Some details:
Having a Fritz!Box 6590, with FRITZ!OS: 07.12.
Created a specific user to acces the Nas (and only the nas) Only acces to a music folder. I can connect to fritz.nas in a browser. Also Windows is connected.

Installed on a Raspberry Pi3. I do have little Linux knowledge and can connect to ssh.

Help me Obi Wan Kenobi. You’re my only hope.

How can i determine the exact path?
And is it the path shown in the address bar or Windows Explorer.

Yes, I see what is wrong. The path has to start with FRITZ.NAS, not FRITZ.BOX.

Elements is my USB hard disk. Making a path by yourself shoudn’t be too difficult. Just add the maps divided by /. But FRITZ.NAS/ may be sufficient. Then you will see the internal memory of the Fritzbox and the usb disk automatically.

Okay, I have to admit that I had troubles in connecting with the NAS. But I bought a new SSD card for the Raspberry Pi and a new flash of Volumio: problem solved!

Still not working.

Have tried ver=1.0 and ver3.0.
Tried the path as shown in the picture. But also #/files/WD_700GB/muziek/ as Google Chrome shows it in the address bar.

Within a view days i got a new Pi. With a new SD card. I will install Volumio on it and trying to mount.

Hi, try what I did and solved the problem.


Bij het pad staat FRIRZ.NAS! Heb je dat al gecorrigeerd?

Unfortunately, yes, I saw that error too.
At the Options I also read the difference between ver and vers (with an s), but I still don’t have it working.

What does your path look like in the browser?

This is my path; not too complicated.
Options: none

And here are my settings of my FritzBox under Home Network / USB Storage.
You have FRITZ!OS 07.20?
And with VLC I can use the Fritz Media Server too. Works nice.

1 Like

Change of plans.

I got a Synology Nas.
Just installed. Copied some music to it. Tried to connect with Volumio. First try connected. Easy peasy.

So all my music files will be copied to the nas.

A real NAS is always better. May be in the future I will buy a NAS also. For now I like to try the cheap solution with the Fritzbox.

1 Like