Problem adding network drive

I searched the topics but was not able to solve my problem so here it is:

After upgrading to version 3 the music library on my HD (attached to the router) disappeared. No changes to network sharing in Windows. It was working before upgrading to version 3.

When I click on “add new drive” Volumio does not find my drive so I tried to add it manually. No success!

The hard drive is labeled “R7900P” in Windows.
I don’t know the IP address of the hard drive and cannot find it. Since it is connected to the router directly I assumed it would be
That did not work when I entered it.

gets me this

I’d really appreciate if someone can help me with this.


Why do u use a name instead of your routers ip?
I see no where standing give me a name instead of ip!
Btw in the last version somethings where changed that had to do with
The new addons in volumio this could be the problem.

The IP address did not work so I tried the name as the box say “IP address or name”

The ideal solution would be for Volumio to find the network drive when I scan and I did not need to add it manually, but that does not happen.

I think that the name is for a nas
And i think you can better use a ip instead of a name.
Can you try if you could add version i believe you add it in options.

You could try vers 1 to vers 3

I tried vers=2.0 in the option box, it did not work

By the way, the NAS is called ‘readyshare’
that did not work either

Please try to get the ip of you R7900P first.

  • If you connect to your R7900P, the ip you enter in the browser is
  • You’ve installed “ReadySHARE USB Storage Access” on your router?
  • If you connect to he router and verify the path to the disk its: “T-Drive\iTunes”?

If so you most likely need to enter:

But please check the ip as normally is reserved for you modem/internet access point, not for the router

1 Like

Thank you for the info but it did not work.
I ran ipconfig and the router ip address is

Also logged in the router’s admin menu

I added ‘readyshare’ to the path and got this

Any suggestions??
Thank you!

By the way, when I refresh the browser page I noticed that there is one extra \ in front of T_Drive that I did not type

mmm, confusing it get.
The additional \ is nothing to worry about.
Did you also try to connect using cifs? (leave alias, ip and path untouched)

I did with no success

so a short summary:
share \T-Drive\iTunes
enabled protocol on your NAS, is it CIFS or NFS?

if you enter \\T-Drive\iTunes on the file explorer in Windows are you able to connect?

The external drive is directly connected to the router (through the USB input on the router)
so when I type\T_Drive\iTunes I get the log in screen for the router
I hope this makes sense

So you get the login screen of your router but no connection with the share
What kind of router do you have if i may ask to look in to the manual.
It could be that the share is on a other ip.


Did you install this application as requested? Seems the share is not shared as a network drive, since you need to login to the web console.

if yes add a user with credentials for this share and use the same credentials to add in Volumio.

I have been using this drive to stream to volumio until I upgraded to volumio version 3 so I believe the drive has been set up properly

1 Like

have you tried to add vers=1.0 to the volumio setup (options) when using CIFS. As Volumio V2 still supported vers=1.0. Volumio V3 doesn’t.

As I don’t have any other ideas. If you have a paid subscription,
With Premium you also get dedicated support, so the fastest way to get help is to create a support ticket at Jira Service Management

Maybe \readyshare as ip and \T_Drive\ …

1 Like

Thank you for sharing this.
If I remember correctly, before the upgrade when I clicked on music library in Volumio interface I first got readyshare, clicked on it to get T_Drive, clicked on it to get iTunes

I guess I have to experiment a little longer :slight_smile:

1 Like