private / public ssh keys not working ?


I wanted o setup private/public keys on volumio in order to not having to type my password each time I log in via ssh.
I’ve done this on Openelec and it was working smoothly.

I setup the keys (private and public) on my mac. And I move the public key to root/.ssh/authorized_keys. But the password is still asked while login with ssh. At this stage the password should not be prompted if the setup is correct right ?

Then I was not super keen of setting up PasswordAuthentication no in /etc/ssh/sshd_config since I was still prompted for the password at the previous step.

ex1: … spberry-pi
ex2 : … vate-keys/
Does anyone already tried this and manage to get it working ?


Hi Francis

I’m having the same problem - just wondered if you got it working?


I know this is an old thread, but since I ended up here as the top google search result, I wanted to leave a message for anyone else arriving here as well :slight_smile:

This tutorial worked perfectly for me on Volumio: …