Primo, Plugin Logitech Media Server not work, no server access, LMS buttom no function


I am new in this forum and seeking for help. I have a Primo for some time. I use iPad and iPhone for Primo access via Volumio app. I also use plugin Logitech Media Server.

All worked quite stable- no serious issue, until last week after update to Volumino SW 3.449.
After that the plugin Logitech Media Server Version 1.1.4 from January 26, 2022 stopped working. In the plugin setting ist is not possible anymore to access the Logitech server, LMS (right buttom) no function.

I contacted Volumino Technical Service for help. Davide replied writing, sorry this is an 3rd party plugin issue and therefore no help from Volumino. He refered me to this forum and here I am.

The failure description plugin Logitech Media Server:
Message: error loading page, could not connect to server.
After that complete hangup of Volumino app. Works again after app restart only.

Can someone help me? I am no technical expert- so please possibly with easy understanding advice.

Thank you,


1 Like

Try to remove the plugin, then reinstall

Thanks for the reply. I did several times, but unfortunately no success.

You can always do a manual install of LMS:

sudo apt-get update
sudo apt-get install libcrypt-openssl-rsa-perl
sudo dpkg -i logitechmediaserver_8.3.0_1664261103_arm.deb


  1. the provided link does not work, says „The requested URL was not found on this server“.

  2. How to install LMS manually on Primo?

sudo apt-get update
sudo apt-get install libcrypt-openssl-rsa-perl
sudo dpkg -i logitechmediaserver_8.3.2~1679892799_arm.deb
  1. above does install LMS. Just use your Primo <ip-address>:9000 after completion.


Tks, How to access my primo? I work only with my iPad. Do I need a .Mac and conect primo with cable then? Pls advice.

you need to run a ssh session from your MAC to the Primo.
How do I enable ssh connection?.

1 Like

Sorry Wheaten,

I am no IT expert. Whats SSH and how to do that?


you could at least have clicked click on the given instructions…
next is open a terminal on your mac and type ssh volumio@<ip-address>

Okay. Thank you. Will do and will provide you with feedback.


Hello Wheaten,
here I Iam again. I did as adviced. What are the next steps. Please remember that I am not a IT expert :relaxed:


I connected Primo with Mac. But can’t open with Browser with the address as described in the instructions „How to enable ssh connection“. Both links e.g. http//Volumio.local not working- message: can’t find page. But if I go to finder I can see my primo with 3 folders: Internal Storage, NAS, USB. What’s wrong?


there you enable ssh

Unfortunately still can’t open. I do not see this page und sent. Message in browser: can’t open page.

is the primo booted? and are both devices on the same network?

Yes and both in same network

sorry, i would say open a ticket and ask them to help you.

@DED can you help him.

Yes, but both got the error message: can’t open page.