[PLUGIN] MPD OLED - installation & configuration plugin

Thanks for the reply…

Yes, it’s also in stop mode…

I can also do this at [PLUGIN] MPD OLED - installation & configuration plugin - #824 by Don_Frenk

no Sir…I’m good with a soldering iron and machines…But I can’t be used for programming…I went for chalk on this topic… :joy:

If it’s there in stop mode too, it might be a program error, as I see the same in the link you provided.

Hi Thor

It looks like the screen image has also been shifted to the right


Have you configured the plugin to use the Adafruit (SSD1306) driver?



No, I have the as set in the screenshot.


In that case, try using “3. Adafruit…”, as this is for SSD1306 displays, and should be compatible with your SD1309 display.



Thank you!

1 Like

Hi, same error here (Device or resource busy).
What do you mean by “changed the power input”? I’ve tried to change the power supply but no result. The only way is to disable mpd oled plugin, then restart Volumio and re-enable plugin. (read this workaround somewhere in this community).
Thanks a lot


Another workaround is to set the DSD playback mode in Playback from DSD via PCM (DoP) to DSD Direct or vice versa.

Which DAC, which RPI is used? For USB DAC, switch this on before the RPI.

I can reproduce this error so far…

When I switch off Multiroom in sources and restart I get this error…(Device or resource busy)

If I switch off Multiroom, the startup sound doesn’t stutter.

With Multiroom, the start tone and the first song that is started stutters for about two seconds, after which this phenomenon no longer occurs, as far as I have observed.

I have to observe very long pauses to see whether the Spectrum starts again on its own.

Raspberry PI3 B+ & Hat IQaudio Pi-DAC+

Dear Friends, I need your help. I have no knowledge of programing with no background. i was working on the volumio project and got it to work. I then opted for an oled and tried to get it working through the MPD OLED Plugin. Unfortunately i hit a road block when I ran I2C device Scan. I keep getting this error.

I2C Device Scan

No devices were found on I2C bus /dev/i2c-0 because it appears to be disabled.

Devices found on I2C bus /dev/i2c-1 were:


SO if its detected by /dev/i2c-1, why is /dev/i2c-0 being selected. I made sure i selected all the right options. As i understand, /dev/i2c-0 is for RPi 1.

Please help me.


Hello Duncan,

More information is needed…

Which RPI?
Which DAC?..USB or HAT
Which OLED screen?..exact name/type
How was this connected to the RPI?..exact assignment

How was the screen configured in the plugin?


Hi Thor,

Im using a RPi 4, Raspberry Pi DAC Pro with an I2C SSD1306 OLED Screen. connected using the wiring diagram thats explained within the plugin. After reinstalling the plugin, i noticed something strange at the end of the installation. it red this

Checking I2C busses

  • 12C-1 bus disabled
  • I2C-0 bus enabled
    Finalizing installation

So a 0.96 inch or similar with only four connections?
no RES etc.?

Nope! Thats the one I have on hand. is that the issue? May be i can purchase another! Could you guide me on a suggested OLED?

Not really…hence my question. It’s quite simple and should…if I’m not mistaken…don’t use any gpio’s of your DAC, which could lead to a conflict.

Does the HAT work…can you listen to music even when the Oled is connected?

Which Oled is it actually…name/manufacturer…

DAC is working fine.

Its a generic OLED.

I am unable to find any documentation on the GPIO of your DAC. There is a big chance that DAC and OLED try to access the same pins.
You can try to remove the DAC, audio output to headphone and try to run the OLED again. If it’s working this means that there is an incompatibility between the DAC and OLED.
This OLED should work without problems.

This is an extract from the documentation:

We expect the following Raspberry Pi GPIO to be used by IQaudio audio boards
• GPIO 2/3 (I2C)
• GPIO 18/19/20/21 (I2S)