[PLUGIN] MPD OLED - installation & configuration plugin

It’s a Raspberry Pi 3, Piano 2.1 and Kali. The amp is a Gainclone from audiosector.com and the attenuator is a Arduino based LDR volume and source selection controller from Vincent / zdr on diyaudio.com

1 Like

I now have Volumio 3.396 and the MPD_OLED plugin has stopped displaying at all.
Going back to the old sd card with Volumio 2.917 it works.
What happened?
Is anyone currently having a similar problem?

In addition, when mpd_oled is installed, there is audio stuttering when using Tidal Connect, even audio stuttering when starting Volumio.

@rak39 ,

  • What is your hardware?
  • Which plugins and version have been installed?

Raspberry Pi4
Volumio 3.396
MPD-OLED 1.1.1.

I went back to V.378 and after installing mpd_oled 1.1.1. audio playing in Tidal Connect started stuttering, after uninstalling mpd_oled it started playing fine again.

Next step.
After installing mpd_oled 1.0.18 Tidal Connect play without problems. Oled display is working without problems to.

1 Like

after the 7.9-inch touchscreen, the oled screen is now also included.

I have someProbs with the Plugin and wonder if you could help me out.
I´m not very into Linux and this all stuff btw.
(See also Newbie Problem: Failed to open Alsa)

System as following:
IQAudio Pi DigiAmp+
mpd_display plugin with a ssh1106 SPI oled-display
Volumio and PlugIn latest version

My problem is as following, at first power up, Volumio displays an error “Failed to open “alsa” (alsa); Failed to open ALSA device “volumio”: Device or resource busy”

To get my system working, I enter System-Playback, turn off I2C and change the output device to “Headphone”, store this setting, play anything for about some seconds and switch I2C on again, select “IQAudio Pi DigiAmp+” and restart the system.
After the reboot, the system is working proberly without errors. Until I switch off. Then the procedure starts over again.
I also have tested it with a Hifiberry DAC+, same behavior.
Changing GPIO´s brings no other result.
Version 1.08 brings no changes.

Without any hat, absolutly no problems. I even setup a completely new systemimage.

Any help?


You could try removing the plugin and using Adrian’s instructions here (non plugin mode):

Hi Peter

A couple of things that could be reviewed (I am not currently using Volumio, and so can’t help directly)

  1. The error is occurring at first boot, but if you change the configuration and change it back the error does not occur. In which case, perhaps there could be a race condition somewhere when modules/services/daemons are starting up (e.g. starting up the loopback module?) that could be fixed by introducing a delay somewhere.

  2. The Pi HAT ALSA audio parameters may be incompatible with the ALSA configuration and cava (the program that processes the audio for mpd_oled). Setting the headphone jack introduces compatible parameters, and cava starts correctly, and then when the Pi HAT is re-enabled it chooses parameters that are compatible with the open loopback device.


Hello again,

I tried the installation mentioned above and it seems to work properly, even with restart and shutdown, at least with my HifiberryDAC+ and the SPI-OLED.
Didn´t tried the other DAC yet.
I don´t understand why the “official” plugin does not work, but that´s not my job, I guess :sweat_smile:

Thanks for your help.


Thanks for this great plugin. I got it to work on my RPi ZeroW, version 1.1.1.
I have the spotify plugin also installed and GPIO buttons.
I have a small low cost USB sound card attached to the RPi for the audio output.
So after spending some time setting up the plugins, I had my OLED display (SSD1306 I2C) show title and clock and bargraph EQ.
First thing : I had to reduce the number of bars to 2-3. Keeping the default 16 bars, the sound would cut off, every now and then, and reading quality gets really bad.
And after reboot, impossible to play a song : an error message says “volumio fail to open alsa device. device or resource is busy”
I have to disconnect physically my usb sound card and plug it again to be able to read anything. (or switch output device to hdmi and back to usb)
At last, if I want to play a song from spotify, I need to disconnect and reconnect again.
If I disable the MPD_OLED plugin, none of this happens at reboot…
Any idea ?
In the end, I don’t need the bargraph display, I just want the song info and the clock. Any possibility to disable the cava thing (even though it looks really cool) ?
Thanks a lot for your answers

Hi misterraf

My usual player is a Pi Zero W runing Moode, and only using MPD for playback, and that is pretty close to the CPU limit with mpd_oled running. I guess that Volumio 3 with Spotify running uses just a little more CPU, and that is enough to max out the processor when mpd_oled is running.

I don’t know if you can disable cava running with the Volumio 3 mpd_oled plugin, but if you use the non-plugin version of mpd_oled from github

GitHub - antiprism/mpd_oled: MPD, Volumio, RuneAudio and Moode OLED status and spectrum display for Raspberry Pi (and similar)

Then you can stop cava from running by specifying that the audio copy comes from an invalid FIFO, e.g. run mpd_oled with mpd_oled -c fifo,/tmp/dummy. (The spectrum area will still be present, but with no bars displayed in it).


The unofficial plugin used to simply install mpd_oled and execute it manually when it was needed and this worked fine. The people wanted an official plugin Volumio 3 so in order to be compliant with the ecosystem, it was changed to utilise ALSA as directed by Volumio expert @balbuze . This takes care of the audio routing but the problem seems to be that it doesn’t work for everybody all of the time on every system. :woozy_face: Unfortunately, ALSA is not something that I’m able to fix myself but I am more than happy to change the plugin if anyone knows of a better solution. That’s why I recommend to try the manual install as it doesn’t use ALSA.

You can always remove the plugin and try Adrian’s instructions here for the manual install.

Just tested MPD_OLED plugin on the Odroid N2+, works without problems.

Nice! Thanks for the update! :sunglasses: Odriod N2+ you must have loadsa money! :rofl:

wel have is now had.
Had that thing laying around, thought let’s revamp that thing.

1 Like

Hi, thanks for your quick reply. I’ll try that out asap.

1 Like

can the oled screen be connected to the 5 volts of the raspberry pi? I don’t have a 3.3 volt rail left.

I also tried with an external power supply, but then the OLED screen is not recognized by the raspberry pi or does it not work with an external power supply anyway?

No. I think 5v might do some damage but you can give it a try if you have a spare :thinking::woozy_face: Just get a 3.3v drop-down board

According the specs it’s 3-5V. But I would take 3 10K resistors in serie and connect the OLED over 2 resistors.