[PLUGIN] IR Remote Controller feedback thread

As you know, JustBoom and Volumio are working together to bring new amazing functionalities to our beloved music player. They are sponsoring some new plugins, and the first one is the IR Remote Controller:

This Plugin allows to control Volumio playback with an IR Remote and it works out of the box with JustBoom IR Remote, Odroid Remote and Apple remote. Controls: Play, pause, mute, volume, next, previous, seek, repeat and random

First of all, thank you JustBoom for supporting Volumio and sponsoring this plugin. In this thread we are collecting feedbacks and suggestions for this plugin!

Thanks Michelangelo - we are very excited to be helping with the development of Volumio and to bring new features to Volumio and JustBoom Player users. We are very excited about this first plugin as part of this collaboration.

We are excited to hear everybody’s feedback.

And the remotes should also be in the Volumio shop soon as well to make it easier for people to get them!



Thanks for your work!

I have an rpi zero w + justboom zero digi. As far as I know for working IR I have to add two more lines to the config.txt. But it is missing from the installer.


Is there any chance to add it to the next version? Or I have to do it manually?


You don’t need to add anything, since the plugin will load automatically the required dtoverlay and relative parameters.
Just enable it, click on configure, then select your IR and click Save (even if its the JustBoom Remote) and it will just work

Let me know how it goes

1 Like

Thanks! It works like a charm!

I have an A1156 remote and if I add my config files under “/data/plugins/system_controller/ir_controller/configurations/”, I can use it from the UI.
But it would be much nicer if it is part of the installer. Is there any way to add it to the installer?

Sure, just send a pull request to the volumio-plugins repository :wink:

github.com/volumio/volumio-plug … igurations

1 Like

Hi, thanks for your support, I downloaded ir remote controller plugin in my C2+ hifishield plus, and selected odroid remote (which I have), but no luck l, it is not working. Plz help.

Installing Plugin
Plugin Successfully Installed



Here my log…

Hi, new member here. I’ve been using Volumio for a few days now and I’m quite new to Raspberry and Linux. This Remote plugin looks exciting, since all I’m really missing from Volumio right now ist the ability to use my Harmony remote for basic playback commands as I can with Kodi. I installed the plugin, but so far I couldn’t get it to work. I downloaded the remote codes for an Apple TV 3rd gen and selected Apple remote A1294 in the plugin settings. So here is my question:

Does this remote plugin only work with an IR receiver connected directly to the Raspberry’s GPIOs? Or can I use an IR receiver connected via USB (which I do now and it works fine with Kodi)?

I’ve been going through a couple of web tutorials for setting up an IR remote for Volumio, but it all sounds very complicated for someone who has never accessed anything through SSH or has any idea how these commands work. That’s why I was so thrilled about the prospect of just having to install this plugin.

Any help would be greatly appreciated.

In response to wolfram, I believe the harmony remote works with lirc so in theory you should be able to get it working. You would have to get/build some config files and myabe modify the index.js. If you let us know the exact model numbers of your hardware we can probably help you set it up.

I got my volumio box working with this plugin last night (I have had it working with a manual lirc setup for the last year or so). I had to make a folder for my configs (I’m using a Denon RC-1204 remote) and I have a PiFI Digi board which has an IR sensor on GPIO pin 26, so I had to modify the line which sets the dtoverlay. I also had to update volumio as I was running an older version that didn’t have the new cmd line client!

Maybe as a plugin suggestion we give the user the option to select the driver and specify the GPIO pin if they are using an ir sensor which uses GPIO in the UIConfig? What do people think?

I started looking at adding this last night but didn’t finish.

Thanks a lot for trying to help me. But I’m afraid I don’t understand half of what you wrote. As I said, I haven’t got a clue about Linux and I don’t know how to build config files or modify the index.js. I was hoping this plugin would spare me all that. But I’m willing to learn.

Today I bought an IR receiver and connected it to the pins on my Raspberry the way I saw it in two different tutorials. Like this:

So far I haven’t gotten any response when pressing the keys on my remote. I don’t even know if it’s connected properly. When I start Volumio I get some text saying that “lirc_rpi auto-detected active low receiver on GPIO pin 25”. But according to the tutorials it should pin 18. Not sure what that means. And “driver lirc_rpi registered at minor = 0”, whatever that indicates.

Concerning my hardware: I have a Raspberry PI 3 and after copying some command I found on the net (cat /proc/cpuinfo) and entering it in PuTTY via SSH, I came up with this:

Hardware : BCM2709
-bash: Hardware: command not found
volumio@volumio:~$ Revision : a02082
-bash: Revision: command not found
volumio@volumio:~$ Serial : 0000000062f081a9

Does that help?

As you see, I’m totally out of my element here. I’m a Windows guy and next to never worked with command lines. And I’m starting to get afraid that I might clutter up this thread with my beginners questions.

1 Like

I’m not getting the remote (apple remote A1294) not working my infrared sensor is on gpio pin 4, is the infrared automatically recognized in volumio? or something needs it to be customized in the software for my case gpio pin 4.

thank you in advance.

As I understand it, the IR sensor has to be connected to the GPIO pin 18, as in the picture I posted. Maybe it works for you that way (it didn’t for me).

After getting a TSOP 4838 IR receiver and many hours of reading tutorials, entering commands, getting error messages, installing, de-installing, returning to backup images of earlier Volumio versions and starting over again, I’m ready to give up. I would really love to pause, play and skip tracks with my remote as on a real playback device, without having to reach for my tablet or laptop, but I don’t know what more I could try.

Pity, it sounded so good to have a plugin for that.

1 Like

I’ve added the line “lirc_dev and dtoverlay = lirc-rpi, gpio_in_pin = 4” to the /boot/config.txt and I’ll get infrared response when I run the commands> sudo modprobe lirc_rpi and> mode2 -d / dev / Lirc0 but somehow it does not work.

The problem is that I only have to use gpio pin-4 the others are already in use for other things.

It’s a pity that I need to use Gpio Pin-18 is not another way to make the infrared sensor work with Gpio Pin-4?

1 Like

Even in addition, I can not use pin 18 because I have the hifiberry digi + pro board on the pi and pin 18 is in use (see link)

Maybe it’s possible that it’s being implanted so you can choose the gpio pin in the settings of the infrared plugin.

support.hifiberry.com/hc/en-us/ … e-control-

As I said, using GPIO pin 18 didn’t help me much either. Even though I got response like you when using the modprobe lirc command.

1 Like

You need to use BCM 25 (pin 22) currently as BCM 18 (pin 12) is already used by most I2S audio cards.

See here for details - pinout.xyz/pinout/amp_hat

For the next update of the IR plugin, we are working with Michelangelo / Volumio to deliver capability for more​remotes by standard, capability for changing GPIO pin for IR receiver and maybe we should also add ability to upload a lirc config file and have it automatically appear with proper name in the drop down menu. Also the ability for the system to learn remotes too.

Basically what we want, is all of the functionality of lirc but in a really easy to use graphical interface.

Thank you I wil try BCM 25 (pin 22) today en let you know if it works.

Verstuurd vanaf mijn HTC 10 met Tapatalk

It’s good to know the plugin is going to be updated, thanks :smiley:

In the meantime if anyone wants to use a different GPIO I just ended modifying index.js at line 221:

221 exec(’/usr/bin/sudo /usr/bin/dtoverlay lirc-rpi gpio_in_pin=25’, {uid:1000,gid:1000},

I changed gpio_in_pin=26 as my IR sensor is on GPIO 26 and this worked.

the file is at /data/plugins/accessory/ir_controller/index.js (if I remember correctly)

Unfortunately I can’t help or check anything at the moment as my main PC PSU died.

Ok @JustBoom i changed the gpio pin (4) to gpio 25 and still not successful while I get responsive from the command (mode2d / dev / lirc0) so just created my own lirc (squeezebox3) en now its works :smiley:

I have downloaded the lirc file, see link.


By the way i use a remote sensor from an old marantz dv 4200 (RC6200DV part number RC901) and use a logitech harmony one remote controll with a squeezebox 3 software With which it works now.

Or something wrong with the lirc file of the apple A1294 remote or the harmony one is not complatible with the apple remote Or does not work well.

At least for me it works and I’m happy.

1 Like