Player name fails only IP address to access player

Hi, i am having an issue with volumio run on Pi0. I have to volumio on the same LAN. Volumio1 and Volumio2. It worked correctly, using the player name in the browser (.local) the right player had been found. However after playing around the router and other LAN devices i somehow messed it up and now only one of the volumio can found by using the playername.local format. However by using IP address it can be found. Here is what i did so far before i would make a new install.

  1. reset static IP in router and reset router, restart volumio and used dynamic IP.
    2.reset static IP in router and reset router, restart volumio and used statip IP
    3.changed the player name, restarted. the IP address - success playername.local - it can not be found.
    6 check /etc/hosts, /etc/hostname - names are correct.
    The problem really is that though the device can be used/controlled via IOS app, the spotify app does not see it (other is visible) so Iphone can not be played via Volumio.
    Any idea before a i make a fresh install?
    thank you

This is more likely to be a network configuration/topology issue than a volumio issue. Discovery for the .local domain uses mDNS, which in turn uses multicast. Multicast isn’t always brilliantly well implemented on cheap routers, but even when it is implemented well the packets don’t propagate between subnets, or between routers (having a TTL of 1).

If your recent changes added a second routing point, or an additional subnet, or a private network etc, then this would make it impossible to discover devices without a different discovery solution.

I see. So what to do? Complete reinstall?


I think a reinstall may not help, as it’s more likely to be the network than the volumio.

Can you describe your topology and any significant network settings on your router/switch?

I have
-reset my router to factory setting
-reinstalled volumio completely
-flushed DNS table
I have still the same issue
-one volumio device is accessible via volumio.local
-the other volumio device is not accessible via volumio2.local only via its ip address
Network setup is like this:
-volumio 1 is connecting to LAN via POE switch that is connected to router
-volumio 2 is connected to LAN via normal switch that is connected to router

The problem exists only via wired connection with automatic IP. With wireless static ip it works fine

Yes the problem exists only when wireless network is off

did you try static ip on all and did you try a other dns ? ( and as your DNS servers. )

Ok,Two volumio runs on two different setup i.e. P0 with ethernet phat and P0 with enthernet usb.
I interchanged the ethernet adapters: no difference.Why one can be access with the same network setup while the other one not? Different MAC, different adapter different switich.

Hi @Glider - wondering if you had a solution to this? thanks