Playback source for Multiroom


Until now i only had one volumio player (RPI with Allo Boss), with my music on a usb stick directly connected to the RPI.

But I wanted to upgrade to multiroom audio, so I ordered a second player and upgraded to MyVolumio Premium.

Now I’m wondering what the best option is to put my music, so that both players can access it. A usb drive connectet to the router would be the simplest. However I read in another thread, that a NAS is the preferred way. How high are the requirements for a NAS if it’s only used for Volumio? Should it be equipped with an SSD for lower latency?

I’d appreciate any inputs on the experiences you guys made.

IMHO any NAS with gigabit connection will do just fine. No need for SSD.

IMHO even 100MBit/s is more than sufficient :grinning:

Yeah, I wasn’t thinking about the read speed, but rather about the latency with multiple devices reading at the same time.

For audio playback 100Mbps should be plenty. Raw CD audio is 1.4Mbps, and even raw high bitrate audio is less than 10Mbps. Also, unless you have the world’s biggest drive, or a very small music collection, you will be compressing the audio, making it at least 50% smaller.

The only time a really fast drive and network will help is when you ask Volumio to index your music collection, which is an infrequent operation and not typically one you care about the speed of that much.

Essentially a USB stick in your router is good enough because the performance requirements are pretty low, but a NAS is better if you want other features like backups, DLNA access, security, etc.

I might just start by sticking the USB stick in the router, the access times shouldn’t be worse than with a NAS with HDDs. If it doesn’t perform an needed, I’ll invest in a small NAS.

OK, I received my second player. But it’s not working as expected yet, and I would appreciate any help locating my bottleneck.

I have one Pi connected via Ethernet, the other via 5G Wifi. Volumio indicates that the Wifi network speed is about 200 MB/s.

I tried with the usb stick connected to the router or connecting it to the hardwired Pi. But in both cases there is constant dropout, worse if the usb stick is connected to the router.

Is the problem the wifi connection to the second Pi, or the lack of a NAS? The Wifi is very strong, and the Pi isn’t far from the router, with almost direct line of sight. With the PC, I get 5-600 MB/s in all the apartment.

If I need to get a NAS, what is the minimum that I need? Would a DS120j be sufficient?

With spotify, Multiroom works nicely, but I’m not sure if that’s because of the lossy codec and therefor smaller files, or because the source isn’t my local storage. I don’t have any suscription with lossless audio to test with, since I mostly listen to my local music.

If possible, I’d like not having to spend a couple hundreds on a full-featured NAS, since that would be more than what I spent on my Volumio players, being cost-effective was what attracted me to Volumio in the first place. I still have a 1TB SSD laying around, maybe that could be used in some way?

Thanks for your inputs.

Edit: Trying to play mp3 from my USB stick doesn’t work either, so it’s almost definitely the storage causing the problem. Therefor I would really appreciate recommendations on how cheap a NAS can be that’s still up to the job.

Nobody? What kinds of NAS do you guys use?

Depends on your configuration.
I am using a QNAP QTS with 4 bays and redundant network configuration (2 eth cards) , so my Music is in RAID. If one drive fails I still can recover everything. Same goes for the network.
A Synology/QNAP will do the job. If you want a RAID configuration, you’ll need at least 2 bays.

Thank you for your answer. But that sounds a bit over the top for my needs, I have my music on several computers and harddrives, so I have no need of a safe backup.

Today I tried again and even with Spotify it’s not working anymore. I tried everything over wired Ethernet and no luck either . I also tried casting from Windows to Volumio while the 2 players are linked, and that didn’t work either. If a PC can’t stream properly to 2 Volumios, will a NAS really solve my problem?

@Wheaten, does multiroom work properly for you?

I’m starting to think that this might be a software issue, specially since the settings for the multiroom buffer don’t work either.

Maybe I should try with Moode.

Try restarting Your wifi router. These things tend to get a little bit funny and wonky if not restarted frequently. Overall problem with wireless connection is instability. There may be radio interference from other routers from neighbors. Indicated wifi speed is only theoretical, in practice it is always worse and may include many long lasting speed dropouts. Connecting too much devices on same network makes these problems only worse.

Thanks, but no, that didn’t solve the problem. And even over Ethernet it doesn’t work, so I doubt the Wifi is the culprit.

Would you mind explaining how you are playing in multiroom?
I am a bit confused reading about nas and usb connected to your router.

Please explain step by step so we understand how you play and we can better help you

Thank you for joining in, volumio.
I’ll try to make it clearer:
Whenever I try to group the 2 devices together, the audio starts stuttering, like it plays for half a second, pauses for a second, plays for half a second and so on.

I do no currently have a NAS. I’m trying to figure out if using a NAS would solve this problem, and if a very basic NAS like the DS120j would be enough or if it would need a more powerful processor.

I have 2 RPI with an Allo Boss and an Allo Boss 2. One is connected to the router via Ethernet, the other via Wifi.

I first had a USB stick connected to the router, then changed it and connected it to the RPI that has the Ethernet connection, which seems to work a little better.

At some point, it worked when I played music from spotify, but it didn’t work when playing music from my USB stick. I think at that time I had verison 3.233 on one and 3.239 (beta) on the other.

I also tried connecting both PIs via an Ethernet cable, to check if the wifi was the culprit, but that was no better. I also tried an external HDD connected to the PI instead of the USB stick, in case the stick hade a problem, but without success.

I also tried streaming from my computer, using the"cast to device" function in the Windows explorer, but the problem still persists.

I’d be grateful for any insights on how I could solve this issue.

Multiroom is working, but I never use it.

I see you have one of the 2 in beta 3.239. This version is not release because it has a problem with multiroom, exactly the one you are experiencing.

We are trying to figure out the issue, fix it and then release a new version.
I suggest not to go with test releases, since you can get in situation like this one :wink:

Yeah, I was thinking that, so I reinstalled 3.233 on both, but that doesn’t change anything. I also tried 3.245on both, but again, no improvement.

Thanks for your feedback. It’s very useful to us.

The problem here is that on all our test systems multiroom works fine, so we don’t know where the regression is. It would be really helpful if we could contact you to do some remote debugging on your setup. Would you be ok with that?

Sure, I’d appreciate it.

I got it to work!
I completely reinstalled Volumio from scratch on the older PI, and that solved it. Maybe something went wrong when upgrading to V3 or whatever, but now multiroom works fine.

The only thing that still isn’t working is the multiroom settings, the interface is there to change the buffer size, but nothing happens upon saving. So I’m stuck to the 1,5 second default buffer, which seems crazy high (as a live sound engineer I’m used to latencies between 0.1ms for AES50 to 1ms for Dante).