Playback setting with raspberry pi and Topping e30

I am a newbie. Just connected my new Topping e30 to the Pi via USB. Then connected the e30 to my receiver via coax cable. Pi is running in volumio. Earlier setup of pi to receiver via HDMI was working OK.

Question is on volumio playback setting. At Audio output set to USB:E30 and 12S DAC off, dac displays zeros and no sound. At 12S DAC On, the E30 is not listed among the DAC models. Tried some models but with no success.

What am I doing wrong?

From another E30 thread - Playback settings:

RPi 4 > Topping E30 - Volumio v2.882

DSD Playback Mode: DSD Direct
DSD Auto Volume Level: Off
Volume Normalization: Off
Audio Buffer Size: 2 MB
Buffer Before Play: 10%
Persistent Queue: On
Playback Mode: Continuous

Mixer Type: Hardware
Mixer Control Name: E30
Default Startup Volume: Disabled
Max Volume Level: 100
One Click Volume Steps: 10
Volume Curve Mode: Natural
MPD Clients Volume Control: Off

These settings also work for me (RPi4->USB->E30->RCA->Denon amp). Try them if they will work for you. I think it shouldn’t matter which output you are using from the E30 to your receiver

Hi one question do you have E30 in DAC or PRE mode with these settings? Assume PRE mode given the HW volume control?

Hi, yes, you’re right: my E30 is in the PRE mode

I put the E30 in DAC mode and hardware volume setting still works in Volumio. I’m not sure if its actually controlling the volume in the E30 or in software, not sure how to tell.

After your message, I did the same, just to try it out - switched the E30 to DAC mode and it works the same, like you say. I don’t have an idea why is it so. Anyway, it sounds the same to me. So, I left it in DAC mode, since I don’t need my DAC to control the volume.
On the other hand, I will try to find my remote for the E30 and to try to change the volume while in DAC mode - in my understanding, it shouldn’t do it. If the remote changes volume in DAC mode, then the software is controlling the thing… or at least, that’s how I understand it.

Topping E30 DAC vs. PRE-Amp mode

Thank you for this link.

Hi guys

So I’m having the same issue…

When I put the topping E30 into DAC mode, I can still use the Volumio volume control which puzzles as the volume control is disabled when I tried to use with a Chord Qutest DAC.

So currently I have to put the Volume volume at 100% and control the volume using my integrated amp. Is that the best way?

Same here.
I can control the volume from Volumio (which is odd to me), but can’t control it from my E30 (which is like it should be).
Can’t explain that. Maybe there’s some setting I’m missing.
Maybe some of our more knowledgeable Volumio friends here could shed some light on this?

One more thing: I’ve tried to change the volume control (mixer type) in Volumio to “None”.

But, when I do that, no sound comes out of Volumio.

Even if I put it back to “Hardware”, I still need to do a restart of Volumio in order to get the sound out again

So, “Hardware” it is for me and the E30 is in the DAC mode.


That’s strange. When I set it to none, I still get sound output just that the volume control doesn’t work anymore.

None means no volume mixer. So 100%:wink:

Yeah but based on previous poster… he gets no sound when he sets it to none.