Play here and chromecast greyed out

Running Volumio 3.5 on a rpi3b, I cannot enable play here or casting in multiplayer group so, the play here and cast are permanently greyed out … what do I need to do to troubleshoot and to get it working?

Do you have the free version? That doesn’t include these functions.

No I have premium …

I get the following weird message in live log when I try to activate
info: CALLMETHOD: audio_interface multiroom setChromecastPlayback [object Object]
info: CoreCommandRouter::executeOnPlugin: multiroom , setChromecastPlayback
info: Error : CoreCommandRouter::executeOnPlugin: No method [setChromecastPlayback] in plugin multiroom
info: CoreCommandRouter::volumioGetState

I have wiped the sd cards of both my rpi2 and rpib3 reinstalled and same issue, cannot make groups, or chromecast or listen in my browser … none of the premium features work. At this point I have invested way to many hours and I am about to just throw in the towel and give up on this system … It is sad, because I really wanted this to work.

Am I missing something? Is there some other setting that must be set for multiroom to work? Is there some port that needs to be forwarded from the router ?? What else is there to get this to work?

I understand your frustration, but it’s a bit quiet due to the weekend and holidays. It might help to post your logs.

Can you check in the MyVolumio section if you can see your Volumio systems and that they have the green arrows next to them, like this:

As a Premium user, you can raise a support ticket.

yes they are both green arrows … where do I find the logs, I have been looking and looking …

You can generate a link to your log via yourvolumioipaddress/dev

Here’s the correct link

by any chance, do you have PiHole or some kind of firewall on your network?

No piehole, not really a firewall, but a router with only a few ports forwarded …

could you please try to make all connections available on your router, and try again?

I don’t understand what that means? I am allowing all trafic out and all returning trafic … but have no ports forwarded to volumio … what connections would that be

sorry I misunderstood your statement, if you’re sure you’re not blocking any connection on your network the problem is somewhere else.

please open a ticket to obtain dedicated support for solving your issue

I have opened a ticket … but no replies so far … hoping to resolve this soon

Mine broken too, button greyed out. Lifetime.
I was hoping it would be like a uPNP solution like Plex amp where you can listen and access your files from anywhere.

Kind of a pointless feature anyway if I only have one Volumio setup (Rpi4 - DAC).

At one point it was letting me play here on my phone outside the house,if I selected the headphone output on my DAC. I suspect it only worked as it cached the files but I could certainly browse.

It would be handy if the dev could advise any firewall exceptions/whitelisting etc required.


@DED Can you please pick this up with max urgency?

please try to switch OFF/ON the device under MYVOLUMIO DEVICES list (account page) and/or switch OFF/ON the multiroom feature (sources menu)


1 Like

I have done both those things on both my instances of volumio (rpi 2 and rpi3B) I also reinstalled both once, no dice!

Thanks DED that worked (FOLLOWING A REBOOT).
I don’t have multiroom setup but toggled that anyway.

I can now ‘Play Here’ on pc (default sound device, not to another DAC connected to PC but that is pointless anyway :P).