Piano 2.1: DSP 2.2 filters not activated on boot

Volumio Version: all? (verified on v2.779 and current)
Hardware: RPi 3A+, Zero-W
DAC: Allo Piano 2.1

Steps to Reproduce

  1. Choose 2.2 mode, with an arbitrary frequency (I use 80 Hz.)
  2. Reboot device
  3. Play music

Additional Information

It seems like the main outputs are not filtered after a reboot, so my monitors get the full frequency range. (I assume the sub outputs are not filtered too, but didn’t test.)
These additional steps make it work correct:
4. Go to Settings | Playback Options and change the crossover frequency.
5. Save the DSP options.
6. Change crossover frequency again
7. Save DSP options again.
8. Play music :slight_smile:

After step 5 the Piano is correctly configured (just with the wrong frequency), but you can’t save without actually changing something. Hence the need for steps 6 and 7.

It seems like on boot the DSP registers are not sent to the Piano.
amixer -c 2 scontents shows the correct configuration (only the relevant part shown):

Simple mixer control ‘Dual Mode’,0
Capabilities: enum
Items: ‘None’ ‘Dual-Mono’ ‘Dual-Stereo’
Item0: ‘None’
Simple mixer control ‘Lowpass’,0
Capabilities: enum
Items: ‘60’ ‘70’ ‘80’ ‘90’ ‘100’ ‘110’ ‘120’ ‘130’ ‘140’ ‘150’ ‘160’ ‘170’ ‘180’ ‘190’ ‘200’
Item0: ‘80’
Simple mixer control ‘Subwoofer mode’,0
Capabilities: enum
Items: ‘None’ ‘2.0’ ‘2.1’ ‘2.2’
Item0: ‘2.2’