Pi4 wlan problem

Hello, I have a nanosound 1 with pi4 2Gb and I am having problems getting it to stay connected over wi-fi. I have volumio 2.882 installed and can only get a reliable connection using rj45. On first start up, I can log onto the hotspot and set up my network apparently without problem, but when I shut down the pi, it seems to hang and then when I power it up again there is no wlan and I have to use the rj45 connection . I have tried other (older) versions of volumio with identical results. What am I doing wrong? Please help a newbie to pi out.

if you post a log people can help you.
under Send Log or bug report follow the steps and post the link of your log here.

it could be that your wifi has a weak signal then you have to alter the settings in your router.
but if your far oway from your wifi point or walls wil weaken the signal.
and use a 2.4 ghz signal instead of the 5.0 some have. change the channels on your router could help.

Hello dvo, thanks for your reply.
I am almost certain it is not a WiFi signal problem. I didn’t say in my first post that I suspected a faulty wifi, so I installed pi os to check functionality and signal of my WiFi, and it worked faultlessly. The fault only exists in volumio. I will post the requested log file asap.

Well, it appears the fault is now intermittent! I have spent the last couple of hours TRYING to make it fail,and it is connecting every time and solid as a rock. :exploding_head:
Thanks for your suggestions dvo, I guess I’ll repost when it decides it’s had enough (probably as soon as I press send) :expressionless:

i hope it will be good for a long time Steve so you can enjoy volumio :slight_smile: