Pi Top 4 won't recognise SD card with Volumio instaled

Dear all,

I have recenly been lent a Rasberry pi-top4 (complete edition) and when I run the Pi OS software it runs fine. I would like to use it with Volumio in my hifi set up but when I flash Volumio to an SD card (with Etcher) the Pi-top states it can’t ‘see’ the SD card

I’ve tried copying several times and it doesn’t work however each time I load the pi os software it works fine.

I am a complete novie to this so I’m assuming I am making a very simple mistake so any advice at all very greatfully recieved.
Many thanks - J

You did try rebooting the Pi Top 4 with the newly flashed sd card in place didn’t you?

Yes I did try re-booting when I installed the SD card and still the pi-top won’t recognise the card. I’m assuming it still should work with pi-top4?

How do you know “it can’t see the sd card”? Have you tried a different sd card? Have you flashed it again? Did you check the md5sum of the downloaded image?

Pi Top 4 is just a RPi4 in a case isn’t it?

Maybe I have read it wrong but on the pi-top screen I get the symbols (sorry dont think I can attach pic):

sd card - arrow - pi top

also the light by the sd card is red.

I assumed this cant ‘see’ the sd card but may well be wrong

sorry a bit more info if it helps - I am flashing from a mac to sd card and the pi box gives 7 flashes of green light by sd card.

Check the md5sum of your downloaded Volumio image (note that you will need to unzip it and check the md5sum of the actual image and not the zipped file). It should be exactly the same as that shown on the download page.


If the sums match, then reflash the image onto a different sd card. Try again in your Pi Top case.

Edit: it has just occurred to me that you haven’t said if you have CHECKED if Volumio is actually working.

Have a read of the Quick Start Guide …

BTW be aware that the CPU cooling fan may or may not be working with Volumio being installed. I wouldn’t want you to overheat the board in an enclosed space without cooling.

apologies for the lack of knowledge but how to I check volumio is working? and how do I check the Md5sum (doesn’t appear to be in file properties)

how do you flash the volumio image via a program such as Etcher or do you accidentally copy the image to the sd card?

view the instructions because I think you copy the operating system to the sd.

If you read the ‘quick start guide’ then you will see that Volumio is primarily designed to be run headless, that is without a display. The GUI is accessed through a browser on any device on your network.

If your RPi is using a wired connection, then try connecting by typing http://volumio.local into your browser.

If it is using wireless then you will first need to connect to the Volumio hotspot … see quickstart guide.

I also told him that via facebook :wink:

thanks - Yes I use etcher to copy the image file to the SD card but doesn’t seem to be working.

Will try again and see what happens …