PI 3B WiFi check

V’ 3.449, PI 3B, HiFiBerry DIGI 2 Pro.

Lost network connection when I changed Wired to a Static IP but expected the Wireless Auto IP connection to provide a safety net, but it didn’t. Totally missing from the network so I have had to re-install. Before this change I noticed the Network setup screen did not show a Wireless IP. Does this mean the Wireless radio on my PI has died? Is there a way I can check it before I make the same mistake again?

Bump. No suggestions ??

only thing I can come up with is disabling the hotspot function.

Thanks I will try that.
I am building this for a non-techie friend who’s IP range is different to mine so I am reluctant to complete its Setup until I am connected to his Router. Last time I ‘lost’ the PI and had to start from scratch.
I read somewhere that WiFi and Bluetooth share the same firmware control (my choice of term, not sure if technically correct!) on the PI3B. As I don’t use Bluetooth I added dtoverlay=disable-bt to userconfig.txt on my home setup, and never had a problem.
I don’t think Volumio provides this in its configuration.

Any reason you need to assign a static IP directly to the interface?

There are very few reasons to avoid using AUTO (DHCP) configuration these days.

To fix the IP you can create a DHCP reservation on the router.
To find the IP you can ping the mDNS name, volumio.local by default.

If you are struggling to find the volumio hotspot make sure the Ethernet cable is unplugged from the volumio device and reboot it.

The Raspi WiFi and Bluetooth interfaces are integrated on one chip (CYW43455). Both devices are enabled by default but can be selectively disabled in user-config.txt

If you can get an ssh connection or connect a monitor and keyboard you can use the native Linux tools to test the WiFi and Bluetooth interfaces.

From a console prompt the following commands are all useful.
ip link
ip -br address

sudo iw dev
sudo iwconfig wlan0
sudo iw phy0 info

sudo hciconfig
sudo hcitool dev
sudo hcitool lescan
systemctl status hciuart.service

Everything I have mentioned is supported by Volumio.

Thanks for your full reply.
I have used a static IP because of the permission on my NAS will then accept access to my music from the PI. If there is another way to achieve that, avoiding open access, I would be happy to alter it. The IP is reserved on my Router

I have used ssh with PuTTY before but as mentioned above I didn’t want to complete Setup on my Network because of the Router IP difference, 192.168.0.x versus 192.168.1.x . Perhaps I will just have to take my Laptop with me next time I visit my friend to install this Musicplayer.
I should add I only have limited knowledge of all these things, most by way of trial and error!

Decided to go another route and used a fresh Volumio install in a new PI 3A+, which is WiFi only.
I seemed to have swapped one problem for another, I can’t access it to go through the Setup!

The PI does not appear on my network, neither on the Router or with Fing. In desperation I connected a Monitor and it comes up with the Volumio Login and a line saying the WebUI is on, an IP well outside my Router range. So it looks like I have an ssh connection only.
Some suggestions please !! is the loopback IP address of the device and all IP devices have one. When volumio boots the console initially says use but that will change to an IP on the local subnet when the DHCP client obtains a lease. The DHCP client will not obtain a lease unless the device is connected by Ethernet or WiFi.

When the DHCP client fails to obtain a lease the volumio hotspot starts up and you should be able to see the volumio device on the available WiFi networks list of a phone, router, laptop etc. You will not find the hotspot in your router’s DHCP or scanning with Fing, because it is not connected to the network segment.

If the DHCP client has failed to obtain a lease and the hotspot has not started, there is an issue with the network interface; unsupported WiFi dongle, damaged or disconnected ethernet cable, faulty hardware.

ip link will tell you the state of network interfaces.
ip address will tell you if the hotspot is up, as it will have a 192.168 IP address ending in .1

As a last resort you can try editing /etc/wpasupplicant/wpa_supplicant.conf
Reboot and see whether it joins the WiFi automatically.


Thanks again for your detailed reply, very educational, in a good way!
PI3A+ only has WiFi, no ethernet to try.
In desperation I looked up info online about setting an IP from the command line and the Raspberry site showed how to set a Static IP. I tried it and it didn’t work. I then gave up and decided to try my PI3B again.
I flashed the SD card with the same image but using an old Win8 desktop and DiskManager and this time it booted up with both Ethernet and WiFi connections ???
So I have achieved what I wanted without knowing how or why.
I have tested it and it it is fully working playing Radio Paradise Mellow and it works even without an Ethernet connection, so success!