Pi 2 2.031 won't boot

Hi All,

Have a Raspberry Pi 2 model B, with a 16GB SD card that i’ve flashed with version 2.031 of Volumio. When I turn the Pi on, nothing happens, no network, nothing. Plugged in HDMI and the screen is black (but registers a signal). I can refresh the same SD card with Raspbian and it works fine.


Bonus info - I notice that the red light on the Pi stays solid but the green light flashes 4x slow then 4x fast. If i read correctly this is due to a missing start.elf file?

I’ve verified that the start.elf file is present in the boot directory, and have rewritten the SD/tried other SD cards with no luck…

Perhaps you have a corrupted download? Try downloading and flashing again. I wish the Volumio devs would include a checksum. Easy enough to do to rule out download errors.

We have the checksum of the image, look at the download page :wink:

Apologies Michelangelo, you are quite correct

Tried downloading again (and tried a couple of earlier versions), with no luck. Still same issue…

awesome community. Really helped me with my problem.

Anyway I fixed it. Copied over the start.elf and other files from a fresh install of raspian.

MMMM, wait, that could be a great issue. When did you buy your PI2? Let me know

:neutral_face: cant tell if its sarcasm or serious.

Hoping for the latter.

Purchased a week ago, Pi2 B+. Copied over all 4 .elf files (can’t remember the names off the top of my head) from the latest release of Raspbian.

No, it’s serious. Usually, the PI foundation changes some components (like RAM) for every new iteration.
So that means we need to update the kernel once again, to make it compatible with newer pis…
Or, could you please send the new elf files you copied over via mail to info at volumio dot org ?
I will appreciate it

done - but they are the same ones available on the latest raspbian release (2016-11-25) download available from the pi website.

Wanted to say a quick thank you for this thread. Got my Raspberry Pi2b (v1.2) up and working. I ran into the same issue with the 4x flashing slow, then fast with Volumio v2.041 (2016-12-12). Replaced all four *.elf files in the Volumio distribution with the ones from a fresh copy of Raspbian and things are up and working!

Exact same setup, problem and solution for me! So glad I found this solution. Thanks everyone for your help!

PS: would it be possible to include these Elf files in the image by default, to avoid confusion for beginners? Thanks!

Yes, I will make a test image soon with the new elfs

Here it is: updates.volumio.org/pi/volumio/2 … pi.img.zip

please let me know if that works with newer pis

I have just tried this image on a RPi3, and it seems to be working fine.

Thanks a lot for that.

The next time I’ll be installing Volumio will be when the new version supporting “dual mono” on the Piano 2.1 becomes available :wink:
That will be on the same Pi 2 Model B (v1.2)

Same thing just happened to me. New RPI B+, wouldn’t boot volumio-2.041-2016-12-12-pi
I copied the four *.elf files from github raspberrypi/firmware and it boots. I did this today,