Pi 0 W wifi connection issue


I’m new to Volumio and Raspberry Pi.

Since I installed Volumio 2 on a Raspberry Pi 0 W, I couldn’t get it to connect to Wifi.

Added the lines in /etc/network/interfaces with my wifi login

Searched on the forum and noticed that Pi 0 W need another wireless adapter to activate the Hotspot mode.

Please let me know if that is the only way to use the Pi 0 W? If so, which adapter should I get?

When I started with Volumio as a Rookie I had the same “problem” of understanding,

The procedure to get Volumio on a PI Zero W working is:

  1. Install Volumio from scratch
  2. Switch the Pi on
  3. Wait a few minutes
  4. Search with your tablet/smartphone etc. for WLAN networks and you will see a network (hotspot) named VOLUMIO.
  5. Connect your tablet/smartphone with the network hotspot VOLUMIO and enter the password: volumio2
  6. After that you are connected with VOLUMIO on your PI Zero W - but NOT with your WLAN and NOT with the INTERNET.

After steps 1 - 6 you must be able to customize VOLUMIO network setting via WEB Interface with your individual parameters for the connection with YOUR existing WLAN network. And after that REBOOT and that’s it.
If everything is okay, after the REBOOT your PI will be connected to your WLAN. If not, start te same procedure at point 4.
Your will find more information at:
volumio.github.io/docs/User_Man … tart_Guide

HTH and have fun with VOLUMIO.

1 Like

Thanks for your help.

I was able to set it up now. Is the Pi 0 w HDMI OUT work? I tried to connect it to a Yamaha receiver using that and it output no sound

Have you selected HDMI as your output device in the general playback options?

I had a no sound over HDMI to a Yamaha receiver issue but managed to fix it after several hours of googling and trying everything. See here https://forum.volumio.org/sound-over-hdmi-while-audio-jack-and-usb-are-working-t3580-10.html

I took the SD card out and edited the config.txt file on my windows PC. I think I just added:

which forced the Pi to output 1080p @ 60Hz video, which made the receiver to output sound. When I started Volumio, it gave me an error about my HDMI output which I just ignored because things worked just fine.

1 Like

Turns out it was the airplay volume being too low.

I have to really dial up the volume when doing airplay to be able to hear the music.

If I’m playing music from my NAS, volume is good.

1 Like

I wasn’t hoping that I will find this information here, but I actually did. Thank you for creating this topic, OP. And the solution… Well, it was unexpected. You see, my brother is a Cisco certified network engineer. He passed exams on this https://cciedump.spoto.net/ site and now he works in a big company as a network engineer. And because of that I know a thing or two about networks. I fought this issue for hours and then it turned out that the solution was right before me, lol.