OTA Updates... Don't update?

Hi, 2.175 won’t update to 2.201. says updated successfully but after restart still says old version. don’t think i’ve ever had an OTA update work successfully on any version since implemented.

what other options are there to update?

Do a fresh flash of the latest sd card image?? It’s strange that all your OTA updates are not working … do you make modifications to the system or install other software?

I had a similar issue. It turned out I had messed with my DNS settings. Changing the settings to whatever it was Michelangelo told me to try worked. Turning custom DNS Server back to “off” also fixed it.


I have exactly the same issue. The only “customization” I did was to add a NAS and a few web radios (via the GUI). I am able to do OTA updates after a factory reset, but it is tedious to have to go back and add the NAS and web radios. If I delete just the NAS I have the same issue. If there were any easy way to backup web radios, I would also try that.

The OTA quickly goes to 20%, hangs for a moment, and then completes with a message “successfully updated…”. After restarting I’m still on the old version.

Try the new data backup/restore plugin volumio-plugins-collection-t6251.html. You could also simply save the ‘/data/favourites/my-web-radio’ file itself if you have command line access.

Thanks - I tried the backup plugin. It might have worked, but I had no means of moving the backup file off of my flash drive. I manually copied the web radio URLs, did a factory reset and the OTA update worked again.

The backup file is on a samba share so you should be able to access it relatively easily from an external device. As a side note, if you can copy my-web-radio from the command line, then you can also copy the backup archive at ‘/data/INTERNAL/volumio_data.tgz’.

OTA updates don’t work for me either. I’m on 2.041, and when I click ‘Check Updates,’ nothing seems to happen at all. And if I open Chrome dev tools and look at the network tab, it shows nothing. I had the same issue last time, when I was on the last version of 1.x. I didn’t even know 2.0 had been released until I went to the web site, and then had to manually flash and configure it again.

v2.041 is a long way back, and there are some issues. Please backup your setup, and reflash a new image.