OpenVPN x Spotify Connect

RPi400 4gb
Volumio 3.173
OpenVPN UDP connection to ProtonVPN
dhcpcd.conf untouched (previously forcing static domain_name_servers= in an attempt to quell dns leaks breaks tidal connect)

I have openvpn running on boot. I can play Tidal and Spotify from Volumio.

Tidal Connect sees and can play to Volumio from devices on my local network.

Spotify Connect does not detect Volumio when openvpn is active.

What would be causing Spotify Connect not to be advertising a Volumio endpoint while openvpn is active?

Suspect DNS, but Tidal Connect works?

Total GNU/Linux noob here - any / all suggestions highly appreciated.

Tidal connect is written by the Tidal team and Spotify connect… well by a bunch of us in our free time :smiley:

The Spotify client has a setting to show devices only on the local LAN, perhaps disable that?
Also you could try disabling the discovery mode, and enter your credentials via the plugin settings page.

thanks Ash

i have no doubt that this is a networking issue (probs DNS) and not a client nor plugin issue.

local only is off and i am logged in and authorized for Spotify. Everything works if VPN is off. Only Spotify Connect is being hindered by some setting not allowing it to advertise.

If you use your credentials, then it shouldn’t need to advertise. Can you share some logs?

Can’t see anything amiss there - can you try sharing a new one with a fresh reboot (with your VPN enabled)?

Thanks for taking a look Ash! Will reboot and post another log set shortly.

You seem to still be in “discovery” mode - please go to the plugin settings page and enter your credentials to login and connect the endpoint to your account.

i’m convinced i’ve logged in - plugin interface reports all good. and i can see my spotify account within Volumio and play from within Volumio. I just can’t cast to it from spotify clients or web while vpn is connected


Log file captured while playing from within Volumio:

Spotify != Spotify Connect :slight_smile:
Please go to the volspotifiyconnect2 plugin settings and then I believe it’s called “multi-user device” or something like that, toggle that off and enter credentials again…

YES! thank you Ash that works.

any idea why spotify would “just work” while off the vpn and multi-user was enabled?

updated log:

Spotify Connect requires mdns packets to “discover” clients in the local LAN. When you connect via the VPN, this might break.

Spotify (the other one) needs only to connect to Spotify’s servers, so works via the VPN with no issues.

Wort taking a look at your routing table, with and without the VPN active.
netstat -rn

Open VPN can be configured to route all network traffic through the VPN tunnel, and there are options for filtering multi-cast and broadcast traffic which mDNS relies on.