Older volumio versions .img files

Hello everyone!

Does anyone have .img files of previous versions of volumio? The newest version 2.201 is not working very well on my
system so I’d like to downgrade it to 2.185. Unfortunately I deleted the old .img file from my PC and I cannot find it
anywhere else on the internet. I would need the RPi2 .img of version 2.185.

I would be very happy if anyone could help me.

Thanks in advance!

Best regards,


1 Like


Thank you very much!!

1 Like

But just be a little careful when not all are released versions.
Some will work fine and actually have improvements, others just fail because they’re not finished.

1 Like

You are right.
The list containes now only released versions, shown in the changelog:


Need a link to the img file for Volumio 2.368. It is in the change log and someone that I have communicated with is using it, but he no longer has a img file that I can use.

I am having problems with seeing/adding the plugins and he has that capability with 2.368.

Want to see if my problem goes away with the 2.368 version.

Assistance will be greatly appreciated.

Thanks in advance.

PI, Odroid, x86, Tinkerboard or other?
Without that info we have no chance to help you…

gkkpch — sorry about that. 2.368 needed for the Pi.

Thanks for the response.


Not sure using am old version is a solution… What is your problem with plugins?

balbuz ---- I have tried 3 or 4 versions of Volumio (2.389,2.344,2.185, and something else) with my Raspberry Pi 3B and an IS2-type DAC. Music plays well from USB Flash Drive and WiFi. No ethernet cable is attached.

I wanted to use a Waveshare 7-inch (1024 x 600) Touchscreen instead of a tablet, but that needs Plug-ins to be installed and maybe some mods to a volumio configuration file. However, the Miscellaneous Plugins Category needs to be present and visable.

On the versions that I have tried, when I tap Plugins, I always see 4 lines on the screen. Only line 4 has items that are tap-able.

  1. With 2.389 I see a line 4 with 2 items — Search Plugins and Installed Plugins
  2. With 2.344 I see a line 4 with 3 items — Search Plugins and Installed Plugins and Upload Plugin

Taping Search or Installed results in the item being backlit and stays that way for up 20+ minutes when I get tired of waiting and I terminate the operation. The GREEN LED on the Pi never blinks???

Some one that I spoke to has the 2.368 installed on the same hardware that I am using and he has and sees a full Plugins Screen that functions and will display selections that are tapped. He no longer has an image file that he can share with me.

All I want to see is if 2.368 will work on my setup!!!

Question: Is there any link that I can go to and see pictures of the Plugins Page for different versions of Volumio??

I would appreciate any assistance.


this is the link

judydudi — Thank you very much for the link!

Judy — just to let you know, the 2.368 version for Pi works just fine on my hardware. RPi 2B and Ethernet Cable and Flash Drive. Music plays and the Plugins Options come up when selected.

Thanks again.

thanks stew.
it is also my experience that i have to go back, where something works to me as i expected.
maybe one of the next releases will solve your thing.
PS: i updated the link list on page 1 of this topic.

1 Like


Please upload version 2.296 for x86.
Link updates.volumio.org/x86/volumio/ … 86.img.zip not work :neutral_face:

Hi, everyone.

I am able to use Optical Drive(USB LG DVD drive) for CD music playback with 2.444
*also, I can add “TIDAL plugin” (through “volumio_mediaserver”) with 2.413 & 2.444

Other plug-ins work ok, too.

**DO NOT UPDATE to v2.5 as it will hide “volumio_mediaserver” after the introduction of MyVolumio service (monthly subscription).
In other word, TIDAL plugin is no longer free with v.2.5

Second time you write false statements. We don’t block anything. Simply, if you do custom modifications to the system and then update then things are likely to break. I warn you : please document yourself before writing other misleading posts as you are harming the community.

Must say, I have the same experience.
Using Volumio2 complete standard.

Verstuurd vanaf mijn SM-G960F met Tapatalk

The latest version 2.619 does not boot on a C2.
And the links here for oldest version seems not working for the Odroid C2.
Is it possible to have a link for the latest C2 image booting?

Hi, see this: