Old matter: failure on a big hard disk indexing

I decided to write on the forum after many years (yes…) of efforts.

Main point is: after first success with Volumio many years ago, for me now it is impossible to use it.

The Story…
I bought several years ago, 4 boards Rasperry PI model B.
First one was for me as a curiosity test, results were so good that I made 3 copies of that system for 3 friends.
It was probably 2012, I can read now on the old berries 2011 as production date.
I added 4 HiFi Berry DAC, SD cards and power supplies.
A kit was available on Amazon, so a very easy task.
Assembly was a snap, no issue.

I burnt a Volumio version, surely 1.xx, I do not remember when and the number.
Everything ran immediately well for me and then for my friends.
My collection of 3000 CDs saved on an external had disk was scanned and used without any problem.
Of course first run was low: many hours to index the hard disk structure, but after that, system was ready to boot and be active in few minutes.
Two years of use without any problem, on my system and on the other copies.

Then in 2016 a total disaster: we upgraded volumio and since that step we lost access to our disks.
It was evident that new version was more delicate on file scanning.
So we let our devices on our shelves disconnected from amplifiers. Very sad.
Any mutual help was unsucessful.

Yesterday I tried again, downloaded august version (2.599) and made a full run.
One night lost.
System boots correctly, internet radios play well, a small direcory of 30 tracks on an USB key works well.
When I connected hard disk with my full collection, system started to scan, I went to bed when it was at “T” letter.
This morning system is down: no access on network (cabled on my router, not wifi).
If I reboot Volumio, my hard disk is absent, I needed to disconnect it and connect again: of course scan must be started again.
So another night lost…
I use an android Huawei tablet on my wifi network managed by a Fritz router, everything under control.

It is this way since version 2, I think.
1.xxx was solid as a rock, 2.xxx is for me not solid enough.
I tried many times to read in the forum, I know there is an MPD demon issue since years.
So probably not a Volumio matter.

So now, which are possible solutions?
Should I buy new berries to get more power?
Should I check hard disk? On my Roon based big system, same directory structure works well…
My friends have different databases of course, and huge, so where and how do we need to check?

Thanks for any help!