[OFFICIAL] Volumio Mini86 Support Thread

This thread will be a collection of tutorials and help on the Mini86. Please post here your questions and not elsewhere.


In the situation where your Mini86 does not boot anymore (wrong update, manual install of packages or DEV update failure). Or if you have the NAS edition but Volumio allows only to copy few Gigabytes of music, reflashing Volumio is totally possible and it will take about 30 minutes.
You will need 1 USB drive an HDMI monitor and a keyboard to perform this operation.

IMPORTANT: the USB thumb drive size must be same or smaller than your Mini86 internal hard drive. (example 8GB thumb drive will work for both versions of Mini86)
Please note that you will loose all your settings and stored music on Mini86, since you will be flashing a brand new Volumio installation.

1- Download the Mini86 version you wish to flash to your unit. Suggested is version 2.309
LINK : http://updates.volumio.org/x86/volumio/2.309/volumio-2.309-2017-11-04-x86.img.zip
2- Download etcher or win32diskimager:
3- Uncompress the zip file and write the resulting .img file on your USB Drive (CAUTION: Make sure you’re actually selecting your USB drive and not any other drive! If you choose the wrong device you will loose all your data on it).
4- Power off your mini86, connect it to a HDMI display, connect the USB keyboard and plug the boot thumb drive you prepared in the previous step.
5- Turn on your Mini86 and start pressing IMMEDIATELY the ESC key on your keyboard until you see a blue screen come up

  • If you see a prompt asking “Quit without saving” choose no
  • Then using the right key go to “boot” menu
  • Using the down key go down until you place on “Boot Option #1
  • Press enter, you will see selected the internal memory of Mini86. You should also see other entries named differently: this is your USB key. Select it and press enter.
  • Using the right arrow key move until you get to “Save & Exit” menu. Click enter and select yes.
    6- The mini86 at this point will load Volumio from the USB drive. We will use this temporary Volumio install to restore Volumio on the Mini86 internal Hard drive.
    8- When you see the Wizard, complete it. Then, from the Menu, go to system page and scroll down to the end of the page. Click on Install (with the Hard drive name, for Mini86 this can either be Kigfast (8GB version) or HGST (NAS edition). As a safety measure, disconnect all USB hard drives from Mini 86 before doing this.

    9- A popup will ask you to continue. WARNING: Make sure this is the actual Mini86 hard drives or the actual hard drive you want to install Volumio to. All the data on this device will be lost!

    10 - After clicking Yes, Volumio will start the install on the new drive. You will see a progress bar. A typical install will last about 10 minutes.

    11- If everything went right, you will be notified. To restart your Mini with your newly flashed system, simply click “Restart”.

    12- The mini86 will restart, just after the Volumio logo disappears, remove the USB drive. Leave alone the mini86 for about 5 minutes, and at the end you’ll have a brand new install with full HD capacity


By default, Volumio will automatically show the content of USB Hard drives. However, it does not do it with internal hard drives. You can however enable this behaviour manually (some basic linux skills are required).

1- Turn on Mini86 with the second SATA drive connected
2- Enable SSH and connect via SSH ( volumio.github.io/docs/User_Manual/SSH.html )
3- We need to know how Volumio calls your second SATA Hard drive, to so so, launch this command (enter volumio when asked for password):

sudo fdisk -l | grep Disk

The output will be something like:

GPT PMBR size mismatch (7987199 != 30218841) will be corrected by w(rite). Disk /dev/loop0: 512.8 MiB, 537690112 bytes, 1050176 sectors Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors Disklabel type: gpt Disk identifier: 53AA76B3-7419-4D4E-B817-18E18199F778 Disk /dev/sdb: 14.4 GiB, 15472047104 bytes, 30218842 sectors Disklabel type: gpt Disk identifier: 53AA76B3-7419-4D4E-B817-18E18199F778

Assuming the hard drive you want to mount is 14.4 GB big (you should use its size to identify it), take note of its device name, in this case /dev/sdb

4- Create the mountpoint for it on INTERNAL folder with this command:

mkdir /mnt/INTERNAL/MYHD

Instead of MYHD, feel free to call it however you want

5- Now mount if with this command (NOTE; We added 1 to /dev/sdb, making it /dev/sdb1. This will mount the disk’s first partition, if you want to mount the second partition use /dev/sdb2 ecc):

sudo mount /dev/sdb1 /mnt/INTERNAL/MYHD -o noatime,dmask=0000,fmask=0000

6- Now, check if its mounted and music is recognized, by updating the music database from MY-MUSIC. If yes, congratulations.

7- Now, we want to make this settings persist reboot. To do so:

sudo nano /etc/rc.local

and add the same command you used before just before the “exit 0”

Save and exit (ctrl +x )
IMPORTANT: Do not add anything on /etc/fstab file (which would normally be a sensible thing to do), as it might break your installation

8- Reboot and enjoy

1 Like

Hello Michelangelo, thanks for your guide.
There are two typos:

  • Will/Wait until the UI is showing, the/then press ctrl-alt-F1 to open a terminal session

Furthermore (correct me if I’m still sleeping and I didn’t read correctly) it seems to me that you didn’t outlined to prepare two identical USB sticks (at least, this is what I think one should do, reading last part of your explanation).

My repeated attempts to restore per the guide were unsuccessful. Here is a screenshot of what happens when I try to boot from the USB stick:
Volumio restore fail.JPG

Patience, Persistence, Perseverance… Voila!

Volumio sure likes great on a big HD display!

Indeed. Adjusting the aspect ratio helped a lot (the 16x9 setting I use for TV cut off the leftmost characters, as seen in my previous screenshots).

UPDATE: Me and Gé will work soon on adding to Volumio a super simple way to install it on HD, making it possible to restore without all this fiddling


after about 6 days of uptime, I cannot access the web gui anymore on my Mini86. It shows the dark “work in progress” screen permanently (with the 8 rotating circles). Additionally, the screen turns bright every second for a very short time (tenth of a second).

The work in progress screen looks like this:

The screen looks like this when it turns bright approximately once per second:

Then, after approx. a tenth of a second, it shows the rotating “work in progress” circles again.

I was able to ssh into the console and reboot, and now the problem is resolved. But I have seen this happening before. Can you give me some instructions how to provide e.g. log files or else for investigation, if this happens again?

The Mini86 is connected via LAN to my wireless router. It has a fixed IP address and runs Volumio 2.254.

Kind regards

You have an intermediate version. To avoid the issue you have 2 options:

  • Go to factory settings
  • Wait few days for a new update

let me know

I’ll wait for an update then.

wise, we’re very, very close to release…


You may like to know I successfully updated my Mini86 from v2.201 to v2.295, and (today) to v2.301 without incident. Keep up the good work. :slight_smile:

Great, thanks for reporting! We think we have finally solved all the issues with the new updater on x86… If other people will confirm this we can start rolling out new releases and features for X86 and Mini86 finally…

We will also add a way to install Volumio from USB to internal HDD finally (thanks gé), so it will be way much easier to recover a bricked mini86 (and also expand to fill all USB drives)


I have updated to v2.201. Any idea why I do not get any newer versions displayed when checking for updates?


Assuming you are willing to risk ‘bricking’ your device, by running unreleased code (as I did), and you know enough Linux/Unix to manually restore your device (as I had to do), you will need to enable Test Mode (as I did; naively). Point your browser at volumio.local/dev/ and click “True” beneath Test Mode. Note: the button will not change color, toggle, or otherwise confirm your leap of faith; where no one has gone before. Have fun!

Happy to report I have successfully updated from v2.301 to v2.307 (after a couple of shots of whiskey). Jokes aside, I sincerely want to help, in some small way. I experienced another loss of control running v2.301, where the Mini86 was ‘live’ in the sense that AirPlay (from Spotify app on iPhone 6) worked fine, but the Volumio app could not find my device.

Update: loss of control (volumio.local => the web server is not responding; volumio iOS app search for device fails) persists with v2.307 and is reproducible by doing lots of search activity in the app. Interesting that volumio’s web server eventually recovers, if you’re patient. Also: the updater apparently has regressed in v2.307; ‘check for updates’ dims iPhone screen, then hangs. Hope this feedback is useful.

I believe updates are more effective with a Rittenhouse rye manhattan - straight up of course!

Ok, two good news in a row:

  • New version for X86 is available, and everyone should be able to update without troubles
  • The new version allows to install Volumio on a different hard drive, therefore it can be also used to restore a bricked Mini86 (or to restore full capacity on the NAS edition).

Let us know how it goes!

It seems one cannot update from dev v2.307 to release v2.309 (the updater hangs). Although my device is not bricked, I believe the only path forward is to boot from USB, and re-flash either a previous release or the current release. I’m inclined to install the latter, and will report back.

While running v2.309 release on 8GB USB stick, attempt to Install to KingFast returns the following error:

Install to Disk failed: Cannot install on this Disk: destination Disk must be bigger than source disk

Thus it seems one cannot install to Mini86 internal storage (8GB) from an equivalent size USB stick. Sigh.