Odroid C2 + VU7+ : no picture

I’ve a Odroid C2 and a VU7+ display of hardkernel as well. The resolution is 1024x600 and I adjusted the boot.ini in the bootpartition accordingly. However: I don’t have a picture on the display at all.

Does anyone has any idea?
Thanks in advance.

double entry

The current C1 and C2 versions are headless only.
There is no plan yet either, as this has low priority until a plugin for kiosk mode has been developed.

Hmm, so far for my “Touch” successor of my Squeezebox Touch…
But it seems to work, according to the hardkernel site: hardkernel.com/main/products … 5981837236

Yes, sure it works, I have a VU7+ here but really did not have the time yet to integrate the drivers in the Volumio Image.
It will come, I just don’t have it planned yet.
If you could contribute, it would help a lot.

I am certainly welwilling to help, but not the most technical person.
I did some research and if I understand correctly, the VU7+ is the same as this one, only with some mounting holes for Odroids:

According to the site, it is supported by the Raspbian build already, so that shouldn’t be an issue.
However, yesterday I noticed that my boot.ini file listed:

setenv vout “dvi”

While the Odroid-VU7+ site mentioned:

setenv vout_mode  “dvi”

I changed it but no result yet. I need to verify the boot.ini better. Is it correct/loaded. Are there multiple boot.ini’s etc.

To be continued.

All the info is on the Odroid forum somewhere, but perhaps scattered a bit. Basicly you need to step from headless to graphical, there should be enough hints, otherwise ask there

I’ve tried quite something yet, but no success so far.
However: I noticed that Audiophonics has it working:

I never said it didn’t work.
It does not matter how many examples of a working VU7+ you find, our current odroid images do not support it and it has not been planned yet either. Sorry about that.


I don’t have finded in the Volumio forum a thread about how to view Volumio GUI on the TFT display 3.2 ‘’ of ODROID C1 +.

Also I failed to connect an USB 3.0 a 2.5 "HDD 2TB, instead of my 32GB USB stick . I tried but is not recognized.

Kindly, can you send me some valid links about these topics ?



don’t hide C1 stuff in a C2 thread, no guarantee you get an answer :wink:

In this case, please read the thread properly.
I repeat what I have written before, there is no graphics support odriod at the moment and it has not been planned yet. It will come sometime after the first release, but there is no date.

Ok, thank You, but in this case Volumio (C2, C1+ or PI) don’t have an employ in a car ?

I can read the songs titles only in a house lan network ?

It’s an heavy limit for a music player !!

No, without touchscreen support Volumio is useless for a lot of people a.o. car users.
It is a pity it is not working anymore and that it has no priority.

Guys please understand that first we try to make things work as good as possible (in this case C1 and C2, which are proving to be a bit troublesome), then we’ll work on extra features like touchscreen. It’s just a pragmatic approach.

The best thing you can do, instead of whining, is give us code level hints on how to make it happen. :wink:

You’re right.
I’m already trying all kinds of stuff I found on the net. No success yet.
To be continued.

We’re gonna make it videopac… Probably a good bet would be asking on HK forum, what we need to enable video on a third party kernel…

Any news on this?
I tried again this morning but still no luck.
Fresh 2.030 build, waited long (> 30 minutes) for accessing it and installing the touchscreen plugin. It seems to hang at 70%, waited again >30 minutes, then rebooted it (via web gui), enabled the plugin: only very disturbed picture, waited long, no improvement. Had it rebooted again, no improvement.

You need to use this version
Link to the latest (test) C2 image
After downloading the plugin (the 70% thing is still an issue but ok), you need to choose the right boot.ini, they have been prepared in /boot, pick the one you need, rename it to boot.ini and reboot.
Let me know how it goes.


Thanks for your help, but it still doesn’t work.

I do see the bootlog on the screen, till now I didn’t see anything.

Aside from that, I’m confident that the current way of working (with multiple boot.ini’s to switch in between is the best way to proceed. You might want to create a list of supported screens per supported device and then have a .ini file for each screen stating which variables have to be set in boot.ini. Installing a screen should then trigger a script which makes the required changes to boot.ini.