Not seeing new rpi 4 on home network

After having problems with my RPI 3 (corruption of SD card every 10hrs playing or so) I took the plunge and bought an RPI 4 with 8Gb ram. I’ve made a brand new image of Volumio and also fitted my Allo Digone board. On power up, the LAN LEDs show amber and green. 30 minutes later, if I run a network scan, there’s still no sign of Volumio on the network. Logging in to my router, there’s no sign of it on the network map either. Have I bought a faulty RPI 4 or am I doing something wrong? This method worked fine with my RPi3. Thanks

Have you tried downloading the image again and verifying the SD image was flashed successfully?
Quickest sanity check would be to plug in a screen – but you probably need the micro HDMI adapter for the Pi 4…

Balena etcher showed it validated ok. As you suspect, I don’t have a micro HDMI adapter. I don’t know if it isn’t even booting or it’s just a LAN issue. I may try Volumio 3 beta as a tester.

Ah, I vaguely recall that the pi 4 8GB might need a firmware update to work with the old kernel, but I could be wrong…

Give the new beta a shot!