Not booting up on Raspberry Pi

I have a setup running Raspyfi 1.0 successfully. I have been trying to upgrade to Volumio 1.1 and 1.2. In either case, the download checksums match; the image is written successfully; but the Pi never boots up.

The Pi has all its lights on, but there’s no display through HDMI nor is the web interface accessible. I can’t even SSH into the system as it doesn’t acquire an IP through DHCP.

I have tried different SD cards as well; including ones that work fine with Raspyfi.

Can anyone help?

Sent from my Nexus 5 using Tapatalk

Which version of Raspberry Pi do you own? How much RAM does it have?

Model B; 512MB.

I solved this by trying different SD cards. It finally worked on a Sony. What’s odd is that Raspyfi 1.0 worked well on a card on which Volumio didn’t.

What is it about an SD card that makes it work or fail? All my cards are Class 10.

Could also be your sd card reader slot on the pi is broken, its a very common problem and sometimes hard to determine (I have the same problem, solved it with a clothespin:-) … 46&t=16222