Not Booting -> Failed to start LSB:NFS support files...

Just bought a brand new intel NUC5cpyh put 8Gb Ram and 120GB kingston SSD in. Flashed Volumio X86 onto usb. The boot process fails and I get this message
[FAILED} failed to start LSB : NFS support files common to client and server…
See 'systemctl reboot" to reboot …
Give root password for maintenance
(or type Control-D to continue)

Pressing control D a million times just comes up with the “Give root password”

I tried typing volumio in for the password and then I get root@volumio:~#

I can do a few basic things like fdisk and blkid and I can see my ssd there as sda but cannot mount it?

Not sure where to go can’t seem to find anything in a search on forum?

Does this have something to do with permissions of the nfs files and directory on the usb drive I am booting from? I tried to change them but have no luck?



I’ve just tried the NUC5PPYH (which has only a different CPU) and it flawlessly boots from USB using the latest image. What software did you use to write the image to your USB drive? dd works for me. If you’re on Windows I think “win32 disk imager” should work.

At the moment I do have a problem booting the same image from interal SSD but that’s a different story.

Thanks for the reply. Used terminal on mac and dd command
Dd if=volumio.img of=/dev/disk3 bs=2m

Volumio.img is not the exact file name I’m on my iPad at work but I used the file I downloaded from the website.

I have seen variation on the dd command with the bs=1m. Not sure what this does?

Any hints?

If you get it working on this ssd can you update me on anything that might be helpful in the process.

Thanks in advance

The problem is not NFS, that just occurs because something vital already failed before that.
It looks like your boot partition does not get mounted properly which causes the boot process to go in emergency mode.
This puzzles me a bit, as the initrd finished without problems…
The tricky thing is to get hold of boot output, that would be of great help, even a smartphone video from the console would help

Either one should be fine - see dd manpage

bs=BYTES read and write up to BYTES bytes at a time

Just to be sure: your command was something like

dd if=volumio.img of=/dev/sdc bs=2M

right? You will have to write it to the device sdc not a partition like “sdc3” or something.

got it, see this post.

but if you intend to install Kodi as well you’ll be out of luck for the moment:

"The integrated Intel HD graphics adapter does not work with Debian Jessie. It is working with Debian Stretch (Testing). "

Thanks for the hints. I sorted the problem out. It was the USB drive it was somehow corrupted. I obtained another one and went through the process again without issue. I then promptly threw the troubled drive in the bin.

Thanks for the help.

I’ll now try the instructions to get the image on internal ssd drive.


I have an Intel NUC NUC6i5SYH and using the 31-10-2018 PC dist which also ends with a failure to get nfs running.

I dumped the journal file and took screen pictures of the errors that led up to the install failing, here’s the errors:-

scsi 0:0:0:0:0 Direct Access ATA Samsung SSD 845
i8042: No controller found
Failed to mount /var/spool/cups
Failed to open /var/lib/systemd/random-seed
an ACPI driver is available for this device, you should use
Failed to start Various fixups to make systemd work better
Failed to start Load/Save Random seed
Failed to create rfkill directory
Failed to create /var/lib/nfs/ : No such file

Is this any help in diagnosing the fault?

NB/ I’ve already had Daphile and AP Linux up and running on the same box if that helps?

Just to make sure I got it right: was this done after copying the image to the local drive or while still booting from USB?

Parts of the boot log won’t necessarily help, it is not only about the error, but also everything that happened before that.
Could you cut&paste the whole logfile from “dmesg > /boot/NUC6i5SYH.log” (or “sudo journalctl --no-pager > /boot/NUC6i5SYH.log”) into a code block?
You have to transfer the boot log to somewhere else I suppose, but /boot is on a FAT partition, you should be able to read it on another machine.
If it is on the internal drive, boot from a usb disk afterwards and transfer. Do not a disk with Volumio onn as that will NOT work! (takes to long to explain).

Meanwhile, could you also try the dev image from the following page to check whether we already solved it?
Reason: the Debian kernel from the official download version is very old (3.18.25)
We are working hard to get a Volumio version based on Debian stretch, it will have the newest kernel (4.19.2).
The dev image is a pre-version (mix between newer kernel and old volumio) and has a much more recent kernel and supports many new X86 hardware configurations. When we’re lucky, your issue has been solved too.

A second thing to try is a quick modification of the BIOS secondary power setting, uncheck “Native ACPI OS PCIe support” and see if that helps.
Re-check it if it does not make a difference.

Thanks for your ideas I’ll try with the new image this evening.

To avoid the ‘findfs unable to resolve UUID error’

// My install procedure was
Clear down the partitions and create new one using the APLinux boot (cfdisk)
Installed volumio via USB

Also I tried installing directly to the HD from a pc, when I inserted it in the NUC volumio booted but had no networking capability.

networking issues would be resolved with the dev image

Install succeeded and I can access volumio via a browser. Also managed to connect to my synology drive but unable to browse it or login remotely.

I shall revisit the forums tomorrow to try and sort out issues but yes I managed to install on an Intel NUC6i5SYH.

glad we got that sorted.
Seems you never mentioned the ‘findfs unable to resolve UUID error’ issue.
That would have helped too.

Could you perhaps also give a small feedback re. networking, both lan and wireless?