Not able to enable WiFi


I have a Raspberry Pi 3b with Volumio 2.246 using the internal WiFi module. As my router was sending on channel 13 I already applied the regional code to the needed files and afterwards was able to see its SSID inside the wireless network list. Additionally I manually fixed the channel to number 7.
Now my issue is, that no matter what I try, I am not able to enable the WiFi inside the network menu.
First I tried to set the enable WiFi switch to enabled and saved with the result that I get two pop-up messages telling me that the new network settings got active. But when I leave the menu and come back or also after a reboot the switch is on the not enabled position.
Second try was entering the password for my WiFi network and click on connect button. After a short hourglass I am returned to the playback screen. Checking the network menu shows that I am still not connected to the router and WiFi switch is still on not enabled position.
This is just the same, when I am connected to the router via ethernet (which works flawless).
Strange is, that the Hotspot is working without any issues. Enable it, connect via mobile phone or laptop WiFi and go into the network menu. All that simply works, but when I try one of the two steps above it is again just the same.
Am I doing something wrong or do I have to change another configuration file to enable the WiFi?


I can confirm the same issue. New install of volumio 2.246 on a rasberryPi3 - hotspot works flawlessly, ethernet connection works fine. Unable to set-up wifi. On the browser interface network page there is a list of local wireless networks to connect to - none of these give the option of entering a password. Manual entry of a wireless network allows selection of wpa2 encryption, entering network name and password. Turning hotspot off, entering ‘save’ of settings initiates a reboot, however there is no connection to the wireless network made and the hotspot jumps back on.

Any pointers?


I have resolved this issue after some mucking around - my wifi protocol was erronously open (I thought it was WPA2 encrypted) - and I was trying access wifi from volumio using a wpa2 protocol which didn’t work. Hotspot and Wifi works as it should on Rasberry Pi 3 for me. Thanks!