non-i2s dacs

I’m trying to get volumio running again after a year or two away from it.

I’m not so familiar with i2s - does it mean that USB Dacs no longer work with Volumio (using Rpi2)

I have a PCM2704 USB Dac - … 00051.html

I don’t think it’s i2s right? Which means it can’t be used?
I’ve tried lots of different options in the config dropdown but no joy.


Volumio 2 works with i2s & USB DACs. There are some DACs that people have reported to cause problems for one reason or another … have a look at the compatibility list here.

Thanks for the info.
I somehow missed that there was a USB Dac option in the dropdown!
Found it there and it worked after restart.

Hmm, I see why I missed the option… it wasn’t there!

Is there some kind of logic that only displays it when it sees a USB DAC connected?
The audio output somehow un-configured itself and now I can’t see any option for USB.
All I get now is Audio Jack, HDMI out and Hifiberry DAC (probably because I had clicked i2s dac option previously and restarted).

Any idea why I’m not seeing the USB option?