node red


is it possible to install node red on the same pi where also volumio is installed
everytime that i installed node red volumio stops working

can someone tell me of its possible


The IoT diagramming tool? Looking at it, there’s a Linux issue with package name conflicts ( … s-and-node) which might be the start of your problems. Thereinafterwards, you’re pretty much on your own, I fear. Volumio is intended to be the sole inhabitant of a small computer, not really good at sharing. The idea would be to get more RPis and give each of them a role… I think you’re heading in the wrong direction by considering Volumio as a software tool that can be used with other software tools in the same environment. You may be right but…

Chris M

Chris ,

Thanks for your answer !!
I thought volumio is not so heavy so I put it on. I think it is wiser to put it on the domoticz pi .


Hi Gerwin

Did you have any further luck in running Node-Red in Volumio? I have tried it many times and stil with the same result as you, the web UI is not working… It is still possible to access Volumio via Terminal. Did you also have that possibility?
I have successfully used node-red together with MoodeAudio, but not sure if the raspbian OS have something to do with it. I believe Volumio is running on the Jessie OS, the lite version of rasbian. I think moodeaudio is running on the Rasbian OS… Maybe it has something to do with it…

It could be really nice to be able to run both the Volumio and Node-red at the same Pi.


Its not working the right way
I have also a pi with domoticz so I put it over there
And running without any problems


Okay. Thanks for your reply Gerwin.

For the Volumio Team: Do you think there could be any solution to this issue in the future? Or du you know any work around?

Thanks in advance :slight_smile:

Regards Mikkel