No space left on device


I have flashed volumio-2.834-2020-09-24-pi.img onto a 32 GB card and put it into an Raspberry PI3. I made some settings and installed the touchscreen plugin. Installation worked but the touchscreen itself did not. I uninstalled the Touchscreen and tried to re-install but now I get:

ENOSPC: no space left on device, mkdir ‘/data/temp’

I logged in through ssh:
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p2 2.4G 854M 1.4G 39% /imgpart
/dev/loop0 366M 366M 0 100% /static
overlay 274M 264M 0 100% /
devtmpfs 494M 0 494M 0% /dev
tmpfs 509M 0 509M 0% /dev/shm
tmpfs 509M 5.0M 504M 1% /run
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 509M 0 509M 0% /sys/fs/cgroup
tmpfs 509M 17k 509M 1% /tmp
tmpfs 509M 0 509M 0% /var/spool/cups
tmpfs 21M 1.3M 20M 7% /var/log
tmpfs 509M 0 509M 0% /var/spool/cups/tmp
/dev/mmcblk0p1 63M 60M 3.6M 95% /boot
//NAS4FREE/smbData/MUSIC 3.5T 2.6T 838G 76% /mnt/NAS/smbData
tmpfs 102M 0 102M 0% /run/user/1000

…and it seems the partition has not been expanded. Can I somehow expand the partition manually?

This won’t work on Volumio2, there’s no raspi-config and no expand_rootfs command or script.

1 Like

Solved: It seems that Volumio2 resizes the partition when it is started for the first time. When rebooted too early or plug-in installation takes place too early then things fail. I reflashed the card and now it works.