No sound with my usb/spdf interface

My usb/spdif interface is seen on volumio ( audio output “hecate armature” selected ) by there is no sound at all
Then I choose an direct usb output on my dac ( audio output “usb audio” selected ) it’s working.
What can I do ? How can I do with my interface ?

Thanks for your precious help !

Can you check with your soundcard vendor if it’s compatible with Linux?
Check also if there is a firmware update for your soundcard: this usually solves linux compatibility issues.

thank you for your answer.
My interface is “Plug & Play sur Linux UAC2” as they say.
DO i need an différent driver ?

What options do you have in the Outputs list?

I’ve got 4 options in the output listbox :

  • HDMI
  • HECATE ( the name of my interface )
  • spdfi fideo ( something like that )
  • audio jack

When i’ve got a direct output on my usb entry’s dac, I can choose " usb audio"
Something odd : before I’ve downloaded the new volumio version, I plugged directly my usb cable on my inteface without change the volumio parameter ( “usb audio” still active ) . It’s work ! But I’ll to check this solution tonight.
DO volumio need an “usb audio” output even there no “usb audio” output ?

thanks a lot for your help.

The output options are :

  • HDMI
  • Hecate ( name of my interface )
  • Cheapo Audio jack
  • Cheapo SPDIF

Nothing works. No sound at all.
So weird, volumio seems to see my Hecate’s interface.

kind regards

Did you enable I2S DAC?
If yes, disable it, save and reboot.
Then select the USB out and retry. Let me know

The I2S DAC option is disenable/off
The usb output of my allo usbridge is connected to my Armature Hecate interface
I’ve selected “Hecate” in the volumio’s output list
there’s no sound :neutral_face:

Perhaps there’s a volume set up somewhere ?

kind regards

My USB/spdif interface have a usb XMO XU208. There no need, apparently, to download a new driver. Except for a windows environnement.

I’m lost.

thanks for all.

the most crazy thing, everything works before I’ve downloaded yesterday the new volumio’s version.
I never changed something in the volume setting. I was on my old “USB audio” output. I’ve plugged directly my usb cable on my new usb/spdif interface to feed my dad and it was working …

Ok, now we know that it’s on USB Bridge.
Can you connect the USB DAC after boot and see if that solves it?

I’ve rebooted Volumio and my allo usbridge.
It’s working with an direct usb cable to the usb entry of my dac ( “usb Audio” output selected on Volumio )
It doesn’t work with my interface usb/spdif ( “hecate” output selected on Volumio )
Volumio can see and detected my usb.spdif interface ( XMos XU208 with linux kernel, so no need to update or use an adequate driver ) because ì can choose the name of it in the volumio setting. But no sound at all.
The best sound quality is with my interface … so I really need to use it.
The usb entry of my Dac is a bit poor. I’m trying to avoid it.

Good lord, it used to work so fine before the new version of volumio…

I found the solution !!!
It was in the volume setting.
I need to set "material " on with the correct selection of mixer name ( “hecate armature clock N°1” and not “hecate armature clock” )
Treaky. sneaky.

thanks for all and now some music.