No sound over HDMI, while audio jack and USB are working

I am trying to set up Volumio to output sound from my Raspberry Pi over HDMI to my speakers, but had no success so far.

This is what my setup looks like:

  • Volumio 1.55 is working fine on my Raspberry Pi Modell B Revision 2.0
  • Raspberry is connected to speakers with built-in amplifier (Philips Fidelio E2), either by headphone jack, USB sound card or HDMI
  • sound over Raspberry’s headphone jack works fine (but poor sound quality)
  • sound over USB sound card attached to Raspberry works fine (sound quality only slightly better)

-> But: no sound using HDMI. According to my speakers manual, the speakers LED indicate: “Blinks continuously when no audio from the selected HDMI ARC source is detected, or when an unsupported audio format is detected”

I tried changing output permanently to HDMI with “sudo amixer cset numid=3 2”, but there’s still no sound audible using HDMI.

Are there any further settings or options I might try?

In /boot/config.txt put these two lines:
Do this with the root account.

thanks for your hint. I changed it, but there is still no sound using HDMI.

I wonder whether there could be any incompabilities between audio codecs, bitrates and stuff? I am not an expert on this.

You have to edit the file after having configured Volumion with the web access otherwise it will be overwritten.

I added those lines the way you suggested. Unfortunately, no sound either.

Any further ideas?

When connected via ssh, do you see you HDMI DAC with the «aplay -l» command?
Is the jack plugged when you try to use the HDMI output? I have never tried the jack audio output, HDMI output has always worked for me.
I will give you this evening my settings when I will be at home.

Yes, headphone jack (and USB sound card) are disconnected.

“aplay -l” shows HDMI:

And what does «tvservice -a» give?

with “tvservice -a”, there is no output

while “tvservice -s” gives:

So here is the problem, tvservice -a should give you the rates supported by your equipment.
Do you have the HDMI cable plugged when you boot or do you plug it after ?

Stéphane Acounis

Thank you, so I feel like we’re closer to the problem :slight_smile:

I usually have it plugged while booting, but booting without HDMI plugged gives no result either.

If anyone has further ideas how to fix sound I’d be happy.

(this is just to keep this thread up)

Need help with this too. Running the x86 image, have ACL892 and Intel HD SPDIF but no audio coming through from Volumio2.

Same deal here but when the Intel NUC’s HDMI is connected to a NAD M51 DAC’s HDMI input it plays normally.

When connected to an HDMI input to coax/Toslink splitter it doesnt play (Toslink light flashes on for a few seconds upon x86 hardware boot then tuens off. … UTF8&psc=1

I’m going to revive this thread for future reference. I put together a Rpi4 to hook up to an old Yamaha receiver but I couldn’t get audio to work through HDMI. I tried many things mentioned on this and other forums to no avail, and after a few hours I was about to give up and order a hifiberry, but I tried one last thing: I forced a video resolution of 1080p 60Hz as explained in the hdmi_group and hdmi_mode section here and voila! I got audio!

Volumio gave me an error message that the HDMI audio output wasn’t going to work, which I just closed and went ahead anyway and played some music :smiley: My AV receiver even detects when I play hi-res audio (24/96) even though I read on many resources that Rpi wasn’t capable of playing audio higher than 48kHz though HDMI. So I’m very happy now :slight_smile:

Thank you very much danielch. I’ve just upgraded to a Raspberry Pi 4B and my HDMI audio extractor wouldn’t work. But after adding a few lines to the config.txt based on your tip, I’ve finally made it work:


It is also a good idea to connect to a 5Ghz wifi network to avoid interference of the HDMI port with wifi of the 4B.



I have a pi 4, and connected it to my onkyo receiver via hdmi. No sound.
Connected via the hdmi to my Sony bravia TV via hdmi. Again, I thought, no sound.
But normal listening volume on TV is around 10-20 setting .
Our of curiosity, I turned the TV volume setting up to maximum (100) slowly. At around setting 50+ I started to hear the pi output from volumio.
Turning up to around 70 made it actually listenable. But if I switched the TV back to the Sky TV HDMI input, the speakers would destroy themselves.
So the problem may not be no output, but very low levels of output.
On the other hand, I read that someone had tried HDMI audio into another amp, and could get no sound until he set the video output to 1080p @60hz.
So maybe it’s the carrying of the audio signal when the pi doesn’t detect a video input capability on the hdmi end point