No sound after change of web radio station

recently I have encountered a problem with playing web radio station. After a restart I can choose any web radio (even from Tune-In plug-in) and it plays without problem. If I change stations often there is no problem, but if I stay on some station for a while (I didn’t measured the exact time) and try to play another, it accept and “virtually” plays the stream (I can see that stream is going, and play button turns to stop button) but there is no sound at the output. I tried another stream, that plays before but it won’t output any sound until I restart the PRi.
I have this problem with 3 RPis 3 with the latest Volumio, no meter if i have DAC or I play via on-board 3.5mm output (didn’t try HDMI).
RPi isn’t frozen, I could set everything, change stations, but there is no sound. If I leave one station for 24h it plays until I change the station (didn’t try with USB library).
Anyone with suggestion?

I still have this problem with new Volumio. Apparently there is no TuneIn anymore, so I’m using only webradio and I didn’t installed any other plug-in.
So, after a while, maybe few hours, I tried to change webradio station, and the result is that I can’t play anything, there is no sound until I restart the RPi (software restart). RPi is responding to commands via web or ssh, I can choose stations, files from USB, but there is no sound.

I have the same or a similar issue.
I choose a web radio station from the ones I set up in My Web Radios, then if I change station once or twice, the newly chosen station shows as loading/starting with a progress bar, but no audio ever starts. It will never give audio output from a web radio station again until I restart the Raspberry Pi (and it seems to me that a restart via the Volumio GUI doesnt fix it, I have to unplug the USB power connector and reconnect).

I’m using the latest version (2.673), but this has been going on for probably the last five or more versions.
My setup is running on a Raspberry Pi 3 B+ and it’s fitted with an Allo Boss V2 DAC. It’s connected to my internet router via an Ethernet cable.

When I first set up this system in early 2019 it was so good and reliable, playing flac files from a USB thumb drive, playing web radio stations, it was great. But now I’m having endless problems, always having to restart to resolve the radio station change issue, the disappearing music library, and the occasional disappearance of the system on my network.

I’d really like to see some acknowledgement of this issue and an update that resolves it.

Just to add another data point to this discussion, I now know it’s not the hardware or network or anything outside the Volumio OS/Software.
I bought a second micro SD card and installed Moode to it and ran that for several days on the exact same setup, no issues or problems.
Shut it down and reinserted the Volumio micro SD, back to the same problems.
Another issue I’ve noticed is that sometimes the USB drive with my music library on it is not showing in the Volumio app/gui.

It’s a shame that I don’t like the Moode install, it didn’t have any issues, but I found the setup and management a lot more trouble than Volumio, and I didn’t like the interface/GUI as much either.

Same problerm here since last update. its not possible to play internet radio. Tuneln is nor longer possible,
and normal internet radio plays perhaps 5 seconds, the the sound stops. cange to another station is mostly not possible.
Pi zero + hifiberry zero as hardware

i have searching my older backups an i have found an image from last year. After installing this, all work perfect.
Sorry, but i thing i will use this older version, and never make an update in next years.

Something else I’ve noticed about this issue (change station on web radio and no more sound till it’s restarted), once the problem with the web radio audio occurs, the music library also disappears. A complete restart of the Raspberry Pi/Volumio is required to resolve this.

I’m about ready to pay for a Roon subscription and build a Roon ROCK setup on an Intel NUC and outboard USB DAC.

So, I’d seen elsewhere that sometimes a fresh Volumio image (rather than an updated install) can resolve issues with Volumio.

I purchased an additional micro SD card for my Raspberry Pi 3B+ and formatted it, then wrote the current Volumio for raspberry Pi image 2.699 to it.

Installed the card and started the Pi, ran through the config wizard and got the basic install complted and restarted.
I tested with the provided web radio stations, working well, no issues changing between stations, sound plays each time.
Then I added my own choices of web radio in the My Web Radios section (Absolute 80s, BBC 6 Music, DKFM, NME 1, NME 2, 3PBS, 3RRR, Radio 180, Soma FM, for the curious), tested again and also working well, sound continues with each new station selected.

Then I went to my music library USB connected disk drive on the Raspberry Pi.
No drive visible, a bit of messing around, rescanning, updating, etc and the drive was visible.
Music can be played from the USB drive, no issues with the playback and changing songs, etc.

However, I only had one screen full of band directories, about ten, instead of hundreds.
More restarts, rescans, updates, and gnashing of teeth, can see more, but nothing like the full list of band folders.
Also, album artwork was mostly not displaying.
This is the USB drive that was working perfectly with the previous install of Volumio, I had album art displaying (mostly) well, and about 300 artists listed and able to be played.
Left it overnight (thinking perhaps the database building and updating took longer than I’d anticipated), still seemed about the same the next day. On my previous install, I’d only had maybe 10 artists and 15 albums when I set it up, and had been gradually adding more music over the past year of so as I had time or new music.

So I just forced another rescan and update of the music database, now I seem to have all the band folders enumerated, most album art is now displayed, but some still isn’t (I have a correctly sized “folder.jpg” file in each album directory). Maybe it needs another day to complete the database and cover image cache.

Anyway, just wanted to update this topic with current progress and steps taken along the way.