No "Hardware" Volume Mixer Type Option

Using Volumio to control my PecanPi, there has never been the option to use Hardware volume, in the Playback Options > Mixer Type menu. The only options i can choose are Software or None, but None does not provide any volume, it’s muted. Per the the Volumio Instructions…

  • Software = Volume control but loss of Audio Quality
  • Hardware = Best of both worlds, provides ability to change volume without loss of quality

I only want to use the remote for my Preamp but most importantly I want to have the BEST sound quality possible without any ‘loss’ of audio quality.

Hi, I’m thinking of getting a PecanPi streamer. I would like to join the question … how does the volume control in the PecanPi and Volumio actually work for best SQ?

I am thinking about connecting PecanPi to my Hegel H120 integrated amplifier via XLR. How to utilise volume control the best way in that scenario?
And that can be tricky question, but do you think PecanPi will outperform Hegel internal DAC?


The best thing to do is to set the software volume control to 100% and use the knob. If this is not an option for you then turn the knob fully clockwise and use the software volume control.

Yes. I have a few customers already doing this.

1 Like