No database when trying to scan NAS?

I’m trying to set up access to my NAS (Synology 1019+) from Volumio 3.198 on a Pi Zero, and it’s giving me an error that “Command failed: /usr/bin/mpc update mpd error: No database”

I’ve tried sharing the NAS as cifs and nfs, and get the same error on both. On the sources screen I get the green tick that the share is mounted, but then it fails and trying to update the My Music doesn’t do anything (rescan just gives the error again).

Also when I set up the share, the network scan didn’t find anything so I set things up manually (in case that’s relevant).

This did work before under v2, problem is since moving to v3.

Everything else seems to be working fine with the set-up. Any ideas on what may be going wrong or what I can do?

1 Like

Can anyone give me a hand on this one?

Tried it on a second brand new install of v3.198 and that is doing exactly the same error, but also tried on an install of v2.915 that I haven’t got around to updating yet, and with exactly the same server and settings it sees and scans it fine?

for CIFS, please check which version is supported/enabled by your NAS. If I am correct V3 uses vers=3.0 to connect. V2 used a lower one. If your NAS doesn’t support this, you need to add a lower version in options. (vers=1.0, vers=2.0).

For NFS you need to enable this on your NAS and add a user to it. Read the manual of your NAS.

Thanks for the thought, tried both and vers=1.0 fails to mount completely (SMB1 is disabled and not something I want to enable) and vers=2.0 just gives the same error.

The drive is mounting (I get the green tick), it looks like the problem is on the Volumio side with a lack of database:


NFS is enabled and the user has access to the folder - already tested that on another computer via a mount and it works fine. The error above is the same via cifs or nfs.

One other thing I notice is the v2 install does find several devices when it does the network scan, but the v3 install doesn’t find anything. Not sure if that is an influence or indication here or not, but might come into play perhaps?

All three are Pi’s with similar installs, and one of the v3 ones used to connect fine on v2 before it was upgraded to v3. Just seemed odd also that two separate v3 installs are showing the same issue.

What is the result of:

systemctl status mpd -l

And please provide a log and past the link here.

I’ve found the problem.

I’d installed the “Music Services Shield” plugin from the plug-in store, which is v3 only and not on v2. Removed that and rebooted, and now the scan is working fine.

Looks like that plugin doesn’t play nicely with network shares…

Thanks for the time to help with the problem though!

strange, have the plugin running and using a NFS mount without issues. At least you got it solved!

Looking through the thread for the plugin, I think maybe it’s my fault and I misunderstood the aim of the plugin. If it’s trying to segregate different processes onto different cores, it doesn’t make much sense to run it on a single core device like a zero.

I’ve added a pos to the thread as a heads-up for him anyway, in case anyone else hits the same thing.

Try this command over ssh: sudo systemctl restart mpd

That worked well for me.

I hope that helps you out.

Yours sincerely,