No access to synology

As I am new here I first like to introduce myself: I’m an old German guy who once was familiar with programming Z80, starting with ZX81. By the time family and other things became priority and I lost the connection to programming. In the meantime I know how to build websites and did it basically with HTML.
I digitized some of my records to my synology NAS and had the idea to get access to them from my living room. As I had already an arduino and a pi3b+ to learn programming again I found volumio and managed to get it run with the 7" touch screen.
After getting no access from the pi to my synology I read all threads I could find (including the descriptions of synology and volumio manual) but still have no success.
I guess I did all permissions right, created a special volumio user on the synology with all permissions, set the NFS permissions, but still …
I made some screenshots, as I think this is easier to read for somebody who wants to help, but have no idea at the moment how to integrate them into my posting.
If I type in the IP address in the volumio’s mask I get a red error message "Error in mounting share syno - exec error:Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto ‘’ ‘/mnt/NAS/syno’ mount.nfs:access denied by server while mounting
If I type in the synologies name instead of the IP I get an orange error message "Netzwerklaufwerk konnte nicht hinzugefügt werden - exec error Error: Command failed: /usr/bin/sudo /bin/mmount -t nfs -o ro,soft,noauto ‘Syno-NAS:volume1/music’ ‘/mnt/NAS/syno’ mount.nfs: an incorrect mount option was specified

Now when reading (and typing) the messages I had the idea whether there might be a problem with the Synologies name “Syno-NAS” by using a dash in the name. Could that cause the problem? If so, what chance do I have for solving instead of renaming the NAS?

In case I can help anybody with an EMT turntable, I will do that with great pleasure.

Thanks in advance for any help

Hello Hans,

Welcome to this community!

First, to upload pictures you can use the upload function in the text editor:

2020-12-30 11_25_30-Window

The pictures will then be included in your post.

To connect to the Synology you don’t necessarily need the NFS service. you can also work with regular cifs permissions. In my case I use the Synology default shared folder “music” (I guess you’re trying the same) and just created a user account and granted read access to it.

Adding the drive in Volumio should look like this:

If you’re addressing the shared folder “music” you don’t need to include “/volume1/” into the path. “music” will be just right.
A “-” in the hostname of the Synology is not a problem. Mine has that character in the hostname as well.

Let me know if this helps!


Kevin, thank you for a fast answer and showing how to add images.
First: I renamed Syno-NAS to SynoNAS: No success
I have two shares: “BackupSyno”, which contains all my important data, images, … and “music”. I guess there is no default path “music” on my NAS.
Anyway, I now get another Error message.
Please see here my inputs

and the error message is (as I am not allowed to post more than one image:
Error in mounting share SynoNAS exec error Error: Connand failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto ‘SynoNAS:/volume1/music’ ‘/mnt/NAS/SynoNAS’ mount.nfs: an incorrect mount option was specified
I have no idea, which mount option, as I do not specify anyting.
I tried also with cifs: no success:
Error in mounting share SynoNAS (95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Try to add


in advanced option

result: command failed
As far as I read, the option vers=1.0 is for FritzBox or another router. I use a speedport from German Telekom.
I read and tried so many options (also the vers) so my last hope is this forum …

Did you try it with only „music“ in the „Pfad“ field?
If „music“ is configured as shared folder (gemeinsame Ordner) it is not necessary to specify the volume in the path.
If you have a Windows PC you can also try to reach the share with typing \\SynoNAS\music in the Explorer address bar. It should lead you to the correct folder. If it prompts you for credentials you can also try it with the user account you want to use in Volumio.

The security warning you‘re seeing at the password field most probably comes from your browser because the Connection you have to Volumio is not encrypted as it’s Standard HTTP not HTTPS.

I can reach the music folder via an internet browser with typing \SynoNAS\music without being asked for any PW if I play one of the titles. Using only one backslash the search function of the browser becomes active :wink:
Also if I leave out “volume1/” I get an error message saying I specified a wrong mount option

What makes me wonder also is the fact that the message appears “keine Netzlaufwerke gefunden” if I want to add a new drive.

Is this a wrong idea:
Checking via SSH whether and how I can reach the NAS. If this is possible, it should also be possible to mount the NAS in the config.txt. Am I right?
If so, is there anybody who could guide me as I have no experience with Linux. I guess, I could understand what happens, if one would guide me, but I have no idea about the commands.

Besides that: Wich a good and healthy new year to everybody