NFS mount trouble

Hello everyone,

I manage to mount the shared folder where I store my lossless music library from my Synology NAS (DS214, DSM 5.1) using NFS protocol through Volumio web interface.

I guess the folder is mounted properly as I got the green sign next to it. Unfortunately my database is still empty. I can’t see any of my folder.

I waited several hours in vain (I have only 80GB of FLAC so far, not that much I believe). Rebooted my raspberry a few time, I can’t get it work. Frustrating as apart from that it’s working very nicely already with the web radio with my external DAC!

Would love to get some help, thanks

Can you try it only with some Flac files. (if you have a corrupted file the updates goes forever (or at least for a long time))

Sorry for the delay, and thanks trying to help me out.

I created a new shared folder with 3 tracks. Mounted the new folder in Volumio, got the green sign.

Doesn’t make much difference I’m afraid…

Make sure that the “mpd” user and “audio” group owns the directory where your music is stored, and has EXECUTE permissions on the directory.

i.e. if your music is in /mnt/NAS/music

you would do

chown mpd:audio /mnt/NAS/music


chmod u+x /mnt/NAS/music

Thanks bdouble for your answer.

I followed your instructions, but no change… No error in the process, the two commands worked just fine.

In Browse, then NAS, still no folder.