"Next X86" dev (Kernel/ Hardware/ Debian stretch/buster)

Note, this topic has been closed
Meanwhile a new X86 version based on Debian Buster has been introduced as Beta.
Please refer to volumio-x86-debian-buster-debugging-party-beta

This topic is intended for a discussion around lifting the X86 Volumio version to the next level, which includes

  • upgrade to the latest kernel (eventual target is an LTS)
  • support newest Intel/ AMD hardware
  • preparation for Debian stretch with the latest available firmware

Developing and testing an X86 no more difficult than for other devices.
Our problem is that X86 configurations are much more diverse regarding chip sets, firmware and drivers compared with an ARM SBC.
It is impossible for us to do all the testing, we only have a small selection of basic hardware, often not exactly the newest.
That is why we rely on the community, even more than for other platforms.
This is time consuming, we realize that, but we are grateful for anyone willing to help test our development images.
Links to downloads will be posted here at regular times, feedback is very welcome.

A word of warning. These will be Development images, not Release Candidates, some things will be experimental and untested and things can/ will break.
There is nothing new in it for people with older hardware (>3-4 years) as we are not adding Volumio functionality.
But, we are also interested in regression testing on older hardware, so this thread is for everyone willing to help us.

Current DEV version

This is the last test/ dev image based on Debian jessie.
The result of the work (kernel) will be used for our alpha release of a Debian stretch based OS, which we are currently working on.
More information will follow soon



  • eMMC support (with the disk copy function not yet included)
  • support for Intel SST based Audio devices like ES8316, RT5651, RT5640 and more (currently testing with RT5651)
  • support for Intel HDMI/DP LPE Audio devices
  • SD Card reader support
  • boot from USB3.0

Known issues:

  • 16-bit format on bytcr-rt5651 is fine, but with 24- or 32-bit playback playback speed is totally wrong (“chipmunk”-mode).
  • bytcr-rt5651 the wrong mixer has been selected, this should be “DAC1”, also volume should be “Linear”

Here we are, ready and willing for testing…

Mini-pc x86 Gigabyte Brix - GB-BACE-3000 (rev. 1.0)

Features 14nm Intel® Celeron N3000 to deliver to the most intuitive and integrated operating systems in the world
Supports 2.5” thickness 7.0/9.5mm Hard Drives (1 x 6Gbps SATA3)
Ultra compact PC design – 0.69L (56.1x 107.6 x 114.4mm)
1x SO-DIMM DDR3L 1.35V Slots (1066/1600 MHz)
Intel® IEEE 802.11 ac, Dual Band Wi-Fi & Bluetooth 4.0 NGFF M.2 card
Supports dual displays via a VGA and a HDMI port
Gigabit LAN
Audio jack (Headphone/MIC)
VESA mounting bracket (75 x 75mm + 100 x 100mm)
Supports Fan less design



also ready for testing with the following hardware

Trekstor W3 Mini PC with Intel x64 Atom Z8300 architecture
ES8316 AudCodec Device
32 GB interlal eMMC
HDMI 1.4
microSD , microSDHC , microSDXC (max. 128 GB)
USB 2.0
USB 3.0
micro-USB 2.0 (host)
LAN RJ45 (100 MBit/s)
Wifi 802.11 b/g/n: 2.4 GHz
Audio Jack
Fanless silent

The following details can be testet in my environment:

  • Audio files 44.1 kHz, 48 kHz, 96 kHz, 192 kHz in 16, 24, 32 bit depth
  • Audio via 3.5mm audio jack (output to headphones)
  • Audio via HDMI (output to NAD C 510 preamp, refer to my message footer)
  • WiFi (connecting to Ftitz!Box WLAN)
  • 100MBit LAN via cable and Devolo DLAN (connecting to Fritz!Box)
  • Boot from internal eMMC
  • Boot from USB Stick
  • Boot from microSD

Have fun!

Great guys!
I will post the next image based on kernel 4.16 sometime before (or at the latest during) the upcoming weekend.
There will be an image for sure, whether the eMMC copy is included depends on how far I get tomorrow (today was a no-development day).
I might leave that feature for the next version otherwise and just publish the one I’m working on now.
With my board it seems to be OK

From Robert I know he also has Intel HDMI/DP LPE Audio, so we have already 2 units covering it.
This device is a multidevice, meaning it has 3 devices on the same card, where we so far were used to only have one (hw:0.0).
On both units, HDMI Out only appears to work on hw:3,0 what the other two (hw:0.0/ hw:1,0) are used for, I do not know at the moment.
Perhaps Analogue Out and Display Port (the DP in the name) in specific configurations?
I left them out for display on the Playback Options, but they are easy to add when we need to follow up on issues.

@burmar, can you tell me a little more about your audio devices?
No need to dive in deep, in case you have (or can have) Linux installed, an “aplay -l” would already be perfect.
Dev Version 2.374 would be a starting point.

My “newish” equipment:
AZW Z83 II INTEL X5-Z8350 MINI PC (no proof of it being identical to a Beelink Z83 II)
CPU:Intel Atom x5-Z8350 Processor(2M Cache, up to 1.92 GHz)
Storage:eMMC 32GB
SD Card Reader upto 128GB
GPU:Intel HD Graphics 400
Bluetooth:BT 4.0
WIFI:Broadcom AP6255 IEEE 802.11a/b/g/n ,2.4G/5.8G
Ethernet:1000M LAN (RT8169)
Video irrelevant (I assume)
INTEL SST Audio with RT5651 (3.5" Audio Jack with Mic/Headphones)
Boots from either USB or eMMC

Known issues with the Z83 in which I’m very interested to know if others (with possible other devices like rt5640) have these too:
Using the audio jack in 24- or 32-bit mode with the bytcr-rt5651 device will give you a choir of chipmunks singing your songs at record speed and spilling more than a few notes while doing so :wink:
In other words, only usable for 16-bit audio at the moment with a choice to use the resampler to fix it on 16-bit and leave the rest on native.

Hi gkkpch

Well, my audio device is a Lector Digicode S192 Dac and it’s connected to Brix throught usb (Y cable with linear power supply) and iPurifier2.
Brix itself it is also powered throught a linear power supply.
I think i can apply the command “aplay -l” on Volumio in a SSH/Telnet client like Putty?
Or you need info on internal Brix’s audio device?

Hi, yes, our focus will be on internal devices first, in your case the Brix.
No hurry though, this is just informational, so I have a little idea who can contribute with what.
As to putty, yes that will work

I want to test this build on mio2261.
advantech.ru/products/mi%7B% … 854bf1eadf

It is possible add to kernel - module GPIO_SCH311X as module to use Gpio of this board.
Without this I cant use this board in my project to integrate Volumio in Car.
Thank You.

1 Like

yes, i followed your discussions on Khadas VIM :smiley:
Let me finish the upcoming version first, hopefully this weekend.
Then please check if your request has not been added already.
Otherwise I’ll be happy to add it.

Great to have latest kernel build.

Saw the update in Build and x86 platform GitHub.

Wondering what is the command to build it oiversilves ?

Thank you

A new X86 dev version 2.394 has been built, the download links has been added to end of the opening post.
A list of lInks to current and previous versions will be maintained there.

Maybe a stupid question, but does this install the same way as the release version? I was still unable to see the eMMC drive…
Also tried just using the image written with win32, but it kept trying to mkdir with error structure needs cleaning.
This is an Intel Atom Z8350.


There is no difference, they are built the same way and work the same way. The dev version just has a newer kernel and other components that it depends on (firmware).
Flash it to a usb stick and you’re ready to boot from it.

Just read the README.md in the Build repo, it is all in there.

Hi Gé,

thanks a lot for your work and for the new experimental volumio image we all can now enjoy and test!

Let me first give a hint to the other testers: If you wand to use the internal mmc for this volumio image, please make sure thet all of the partitions on the mmc are erased before flashing the volumio image on it. Otherwise at boot sequence the initial ramdisk image cannot be found and the boot process ends up in a busybox command line. Please be careful with the fdisk command! You should definitely know what you’re doing with it! :wink:

Here my test results so far:

  • Logfile: logs.volumio.org/volumio/ojwnzRJ.html
  • Wired LAN (r8152) is working well
  • Wifi (RTL8723BS) seems to work, I get the list of WLAN networks and hotspot is initialy enabled.
  • Playback to audio jack (bytcht_es8316) ends up in an alsa error message.
  • Playback to HDMI (intel_sst_acpi 808622A8) does work. BUT: Files with 44.1kHz sampling rate require resampling to 48kHz. This is a known big sound quality issue…

Please let me know if there is any further information I can provide you with.

Best regards,

I would like to know how to get the eMMC erased. My x8350 came with win10 on it. I think they purposely made it hard to access/delete.

I will do some reading on using fdisc. My linux skills are limited. I’m an old guy from the days of DOS. So, I do have similar experience. Just enough linux to be dangerous!

Any tips would be helpful… Thanks!

I need to thank the testers for taking the time to help make the x86 version better :smiley:

Ouch, I did not test it that way, my eMMC had a Ubuntu OS I used for comparing.
This needs some time to be debugged, not sure yet how this could have happened, even with an older version in place.
I will set up my system with the previous version on emmc and then start like you did.

Thanks for the log, in case you do not intend to use wifi during your tests, perhaps do

echo "blacklist 8723bs" >> /etc/modprobe.d/blacklist-wifi.conf

Otherwise you logs get flooded with wlan0 scanning activities.
(But as long as we do not need the logs, just leave it).

Could you do another log (dmesg output will also do) after you tried es8316?
I guess I already know what is missing, it will probably complain about “No backend DAI links enabled”, meaning there is an ALSA UCM configuration missing.
Meanwhile I will start looking for it, it wasn’t in the Intel guys repo.

Read that already, cannot find how to specify build with experimental x86 4.16 kernel files though,

Anything I missed?
Thank you

Hello gkkpch,
a half year before i buy my “Alfawise X5”-Mini-PC i have ordered the AZW Z83 II
from german amazon.de
i think they are the some, because you can swap the BIOSes of the two devices.
Thats i read in some forums. If it needed, i can search my notices for that.
I know that Beelink has deleted some threads foor the AZW Z83 II in their own forums
perhaps a year ago.

But (!) the BIOS from the Alfawise X5"-Mini-PC has not the same BIOS like the a Beelink Z83 II :blush:
So my first ordered Alfawise X5 is now a nice “Stillleben” (still-life) at the wall, as warning to me :mrgreen:

For the image-testing:
i will do it at the weekend, i am happy to discover this new thread :mrgreen:

greetings, jo01

Yes, you could have had a look at the build script :smiley:
Place a file “.next” in the packages folder of the platform files.
This means you need to clone the platform files yourself before building or do a dry run with the 3.18.25 kernel first and get the platform files that way.

The best way to do that is by booting Volumio of a usb stick or disk.
Then use ctrl-alt-F1 to start a terminal session.
Log in with volumio/volumio and do sudo dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=1000 sync
It wil erase the first blocks of the disk with boot sectors and partition table.
I hope that you know what you are doing, because there is no way to recover win10 after that unless you make a backup on a usb disk (with a minimum capacity of 32 Gb) first.

Backup is best done this way:

  • Log in as volumio
  • verify with sudo fdisk -l that your usb stick is is listed as /dev/sda and no other disk is there except mmcblk0
  • now plug in your usb disk
  • verify it is listed as /dev/sdb
  • continue with

sudo umount /dev/sdb* sudo dd if=/dev/mmcblk0 of=/dev/sdb bs=4M sync
This will take quite a while, be patient and go for a coffee (or two)…