Newbie needs help configuring a Time Capsule library

I just got Volumio installed on an Odroid C1+.

Unfortunately, I can’t get Volumio to access my music library on an Apple Time Capsule 2TB. I can’t get volumio to connect.

I did find this forum post, but I wasn’t able to get it to work for me.

I some experience with Linux, from being in college 15 years ago. So I can open a terminal window on my mac, and SSH to volumio and enter commands. But from there I’m blindly following instructions.

I would be grateful if someone can help me diagnose the problem and find a solution!

Thank you

I solved my own problem. For others with a similar issue… here’s how I did it.

I used this guide for connecting an SMB network disk. It helped me figure out the IP address and the Remote Directory syntax.

I tried a lot of advanced options. It finally worked when I used this option only: “sec=ntlm”.

In setting up the Time Machine, I had to set up the disk on the Time Machine with user-level passwords, and not disk-level or device-level passwords. Also, it helps to make sure the disk is named without any spaces or special characters.

It was really frustrating for a day or so… but I eventually got it working and now it’s flawless.

Latest update: it works even with disk level access rights, not only with the user level access rights. So, if you have any model of the Apple TimeCapsule (with the embedded disk inside), the following item in the extra settings field in Volumio should do the job.

1 Like