new volumio on odroid c2 - it works till shutdown...


Downloaded and flashed new volumio for my Odroid c2. Everything was OK , it played with no issues.

When i was leaving home I tap “shutdown” and “power off” . After a minute (to be shure that it shutdown safely) i turned off powersupply.

When i came back - i switched everything on. But there was no Volumio/odroid connected to my router … (using eth cable of course) , few minutes

later - still no Odroid /volumio… . after 20 minutes i switched it off to take off emmc card and to re-flashing it. (it was strange for me when i plug it in my

pc i got " do you want to scan and repair disk" window … ok. re-flashed it again , plug it to Odroid … and no odroid/volumio in my net…

ok emmc defective - took SD Card flashed it plug in to Odroid - everything is OK .nice. then again - “shutdown” and “power off” ,

after switching it all on - NO VOLUMIO/Odroid in the net … So , Volumio for Odroid c2 became one -time player… till you shut it down.

I hope not - but everything looks like this …

i’ve made a next try - flashed SD Card .plugged it in odroid - OK. works . “Shutdown” and “restart” - it is dead. no more volumio.

flashed again - Ok. works. and again shutdown and power off cycle - volumio dead. Previous image “volumioRC2Fix…” 31-07-2016 works OK with power off cycles… So , something is definitively wrong with the latest Volumio for odroid c2… maybe it is "auto-repartitioning/resizing " ???

ooops it should be in “bug report” could somebody move it there ?

That’s fine here… We’ll investigate on that. Thanks for reporting

OK . I must apologize for this alert - it is not Volumio fault - but my router and DHCP . And for some reason volumio on the next reboot/restart
is invisible for my router . When I took old belkin router and connected odroid and laptop by wire to see what happens when i restart volumio
it shows that on the first time “on” volumio is at let’s say 192…5 IP . after restart it appears at …6 IP and it doesn’t change anymore …
My main router is from my IP provider … DHCP in this s…t sucks maybe … but it worked flawlessly with odroid and previous images…

There’s an explanation for that:
some routers give dhcp based on an hash algorithm that involves SSH keys and other stuff. Since we renew the SSH keys on first boot, then the router gives another IP address. I’m glad this is not an issue!

but… it is strange for me : I bought new emmc card for odroid c2 . flashed with latest volumio image . and… again - it couldn’t connect (on sd card everything was OK) so - connected to the old belkin router via cable laptop via cable too . look at the DHCP clients list - volumio is present but
with MAC address 0-0-0-0-0-0-0-0-0 !!! what… ok. everything restarted. two volumio shows itself - one with “0” MAC and second with “proper” MAC with changed IP. restart again (router too) there is one , “proper” volumio . but UI was very slow and unresponsive with big “lag” …
restarted again ok. works. So , I plugged odroid to my “main” router - it is visible . working .Restarte d again - it works.
Now I don’t know what to think - is it my odroid hardware malfunction (when using emmc card ) or is it something else … somebody could check how odroid behaves wit the new volumio and emmc card ?

And there is one more - could somebody be so kind and check 88kHz / 24bit WAV albums ? no distortions (hiss , little pops) first track is ok next is distorted. (only wav’s higher than 44,1kHz and 24bit but played as whole album - in my case it is Manu Katche 88kHz/24bit) of course flac’s are OK.

It is very unlikely that the odroid hardware is to blame, perhaps google the hardkernel forum for something similar?
In the meantime, can you give me the revision of your C2 board?
And is it with a HiFi shield you experience the 88Khz /24bit WAV issue?


my Odroid C2 board is rev. 0.2
I’m not using HiFi Shield. My audio setup is : odroid-I2S transmitter-I2s receiver -Ian’s FIFO with isolator, reclocker - quad Opus Dac …
these distortions - in previous Volumio everything was OK , no distortions playing every kind of wav’s . Current image - only with 88/24 wav’s (one by one ) for now ; with RuneAudio it was worse because of “heavier” distorted 48-88-96-192/24bit wav’s…

Can you point me to (a part of) such a WAV file?
There is a difference with the old Volumio Version, meanwhile the driver has been changed.
Did you select ODROIDDAC or ODROIDDAC2?

wav’s - in this case it is Manu Katche - “Manu Katche” album bought from HD Tracks in WAV 88kHz /24bit . I have more album’s in a wav format which i didn’t try yet . Wav just because i used Cics Memory Player (before odroid/volumio) and for it wav’s are “native” files.
My Volumio system info shows version 2.002 and there is no “odroiddac2”… ? only odroidhdmi or just odroiddac …

Hi, bought the second track from Manu Katché (Bliss) and it is playing on a C2 with an original HiFi Shield+ without any issues.

Btw. very nice music, I definitely need to check out more of this the artist!

the problem is - in a second or sometimes third track - first is always ok . distortions appears while playing second or third track (I am listening “by album’s” , very rarely by playlist with tracks from different’s a;bum’s) and when i listen one track 88/24 second 41/16 and third 192/24 … the distortions never appears . only when playing track by track from one album 88/24 … so you must buy 2 more tracks… :slight_smile:

I mean - first played wav 88/24 at all . not "second track from album " you can start from third track and fourth is distorted…