New to RPi, Did I Fry My RPi 4 8 Gig?

So, I created an image file on a micro SD card and completely assembled a RPi4 starter kit from CanaKit.
And upon plugging the power into the unit, I got a static discharge between the power outlet and the power supply’s power cord. Did I fry my RPi4? This would explain why the Volumio app never finds a device. Or could it be an issue with my mesh wifi (I use an eero router)?

Thanks in advance for any replies!


Have you tried using wired networking with the pi? It’s usually a lot easier to start that way and you can at least see whether it gets an IP assigned.

That’s the problem with the eero, it doesn’t provide wired connections. The device has two Ethernet ports. One for the modem and another. I plugged the board into the other port. And, then there was no wifi for my phone. Unplugged it and my phone was back on wifi.

I’m planning on placing the RPi about 20’ to 25’ away from the eero. The signal will have to pass through one wall.

The eero units are sold on Amazon. It’s what my ISP provides.

Thanks Again

1 Like

it has 2 ports both could be wan or lan port so you can use the left over port.
and if you put a hub or switch on it you could have more ports.

btw how did you burn the image on your sd card?

I used the recommended app.

did you extract it before burning?
and the recommended app …there are 3 …

I think that first we have to understand if you actually fried it.

  • Do some light come up on the pi when you start it? If yes, which LEDs?
  • Can you connect an HDMI cable and report if it outputs something?

I’m waiting on an hdmi to vga adapter and an hdmi coupler to hook up a monitor. I’ll post when I get them and hook up.

The RPi is in a case I saw at least one red led and one green led light. Also, the installed fan runs.
ICYMI, the RPi has a MAC address on my system but no IP address.


I tried the wired connection again and the RPi4 was assigned an IP address. However, using that in the Volumio app did not work.

I got it to work. For some reason, that I do not know, with the RPi4 wired to the eero, the eero would pause the RPi’s connection to the intrernet. I just went into the eero app and “unpaused” the connection and the Volumio app did its thing!

nice! happy you found out that the router was pausing your connection but a bit strange that it did.

best regards,