Never Shutsdown - perpetual roulette wheel

I’m running the latest Volumio on my RPi4 - with a few gremlins.
When requesting shutdown of the RPi and Volumio, the RPi does shutdown but leaves Volumio hanging in the perpetual roulette wheel.
Closing the app’ on my iPhone makes no difference. Opening it up again just brings up the same old roulette wheel continually running. Its only by switching off the iPhone completely will it shutdown.
Is there a fix for this, please?
Thanks in advance.

1 Like

the „fix“ is at your phone. just clear the browser cache :grinning:

Edit: I want to explain it:

If you shut down Volumio the last thing it is sending to your browser session is the spinning wheel - then it is down and therfore not able to update the page you are seeing at your phone.
The browser on your phone is waiting till the end of times for an update then… but Volumio is down already.
That may be what you are confused about, right ?

There might be a coding solution to make that more transparent - e.g. shutting down everything and give an update to the page “System halted” or similar - but that only would be possible if the webserver that is sending this update would be still up to do that - so it would not be really true, right ?

But you are right - if you do not know what is happening at that moment - that may be confusing.
Now you know :slight_smile:

@volumio or team - please correct me if i am wrong

Best Regards

Thanks @Josh2000 That is pretty poor software when it doesn’t indicate termination of the process.
I’m controlling Volumio OS on my RPi4 via my iPhone App’ and its certainly not a pleasurable experience so far.
In an attempt to know more, I’ve tried to ssh into the Pi from my desktop Linux box but no joy. Message says: ssh: connect to host raspi4.local port 22: Connection refused. I then tried different ports.
So next I connected a screen, mouse, and keyboard to the Pi to change the config settings. VolumioOS started but it kept refusing my login. So where to from here?
Any help would be appreciated. Many thanks.

Regarding your SSH issue have a read HERE

Remember to read the whole document M1ck linked to, at the end it also has the instruction how you turn on access to SSH

Many thanks @M1ck and @Wolfman74 - all is revealed.
Best, Roj