NAS music libraries

Ive just downloaded 2.779 on a rpi3.

All of my music is running on an OMV NAS running rpi. OMV is also accessed by OSMC on other pis.

The music is in one directory, with subdirectory organized by artist then album. Most of the music was audiograbbered from my CD collection though there is a little downloaded stuff.
There are about 250 albums in total.

The problem is when volumio starts up, it stops searching after about 8 artists. If I then reforce a scan/update it finds a lot more, but not all. The spinning icon never stops.

For reasons I don’t understand, It seems to restart the operation from time to time.

Ive had a look in the forum and people complained about same/similar problem many years ago.

Was a fix/cause discovered in the meantime?

Possibly you have corrupted/unusual formatted files that mpd doesn’t “like,” or there are incorrect permissions.

You could try and eliminate this problem by temporarily moving files out of your music folder on the NAS, and seeing if the scan completes.

A bit more laborious approach might be that you get mpd to not search particular directories by including file called .mpdignore containing the wildcard ‘*’.

You could also look at the logs to see if there are any clues there.

Let us know how you get on.

1 Like

i renamed the music directory, and deleted the extra files like album covers, booklets, etc

ive started on a subset of cleaned up directories, but its looking good so far.

thank you for your help

1 Like

How do you share through OMV?

1 Like


It sets up a bit easier in zeroconf browser. I do all directory maintenance from Windows 10 on OMV, and that seems easier to setup too.

Do you think it matters?

No it should not matter but you never know. Could be something with the path. I have not seen this issue before, and I use OMV and volumio for years

Ive checked all of the sub directories on my NAS music server directory.

Ive deleted absolutely everything that is not a media file (*.jpg, *.cue, …) .

to recap the music directory is organised as
artist 1
album 1
album 2
artist 2
album 1
album 2

The update music library never stops. Volumio shows 121 artists, 211 albums, 1371 tracks, nad seems to hang there.

Windows shows 220GB, 6247 files in 677 folders.
windows is saying I have a lot more music. 3750 .wav files, 1663 mp3, …
OSMC which uses exactly the same NAS follows my directory structure says 157 files, hence artists. I can play all the files perfectly with OSMC. I have a hunch OSMC uses the same underlying media player technology as volumio to read the files.

so volumio is hanging half way there.

Could volumio be getting confused and hanging trying to sort my (logical) directory structure into what is an erroneous and unwanted “smart” one? This is what I think the problem is.

In addition I cant get volumio to display the albums it does read in alphabetic order. Is this possible?

Can I set the compilation metadata tag to force alphabetic or just get it to work?

I am having similar issues as well I run first config wizard to trigger scan and it only loads one folder of six and only loads average of 250 items of a 1.16tb drive of music. this as been going on for the last four updates I asked on here but yet no help in solving so I will watch with anticipation this post in the hope we will get help… I tried re flashing with different apps still the same. It also empties the mounted drive on a reboot of volumio.