NAS mount error

When I install RaspyFi had been mounted NAS is well.
However, like the photo after upgrading Volumio an error.
Note that I am a beginner of Linux.

Wild guess here, but is the user “MPD” created as view only in your NAS? Check security…

My NAS is a NAS4free.
And the user “mpd” was created.

I was having trouble mounting my NAS, so I removed everything from the “remote directory” field, then went down to the “Advanced” section and added sec=ntlm to the additional parameters.

I am depending on the advice of shano, “remote directory” field empty, “sec = ntlm” were added.
But did not mount.
See also changed so that the user name and the IP address of RPi view had changed.
As shown below, but only warnings turned into an error.
(Sorry, my English is suck.)

My problem has been resolved.
Setting the shared folder in the NAS routing in “mnt / etc / music” which is set to ‘mnt’ except the “etc / music” has been changed to do the mount.