NAS drive wont share


Im trying to share my NAS drive shared folder but I get errors for both SMB and NFS, the nfs share command that works in Windows is :slight_smile:

mount -o anon \\mnt\array1\Movie_Library Z:

I can browse the folders from the command line using this but i get the error host is down for CIFS and command error for NFS.


What happens in Volumio if you set the path as ‘Movie_Library’ (without quotes) and use cifs?

spaces in a url most of the time a bad thing…
windows handles url different or use under_scores or remove spaces

(changed your line into a code block to get \\)

I had some initial issues adding my Synology NAS music library as a source. The key for me was that I had to specify ‘vers=3.0’ in options for cifs.Relative to SMB, my NAS is set to: Min SMB Protocol = SMB2, Max SMB Protocol = SMB3

Assuming this is what you are trying to do, here are the details of what I did on Volumio:
Settings → Network Drives → Add New Drive
NAS IP Address: Either IP address or Network Name (both worked for me)
Path: NAS share name/path (the Volumio web app will add the appropriate backslashes. This will result in the @evilmrb full path string)
Show Advanced Options:
File Share Type: cifs
Username: Username for the share, set in the NAS
Password: Password…
Options: vers=3.0


vers=1.0 fixed it for me :slight_smile: