NanoSound Official Help

Note that we have moved the NanoSound Official Help forum to

This is the help forum of NanoSound - All-in-one Hi-Fi Audio DAC Board for Raspberry Pi

NanoSound provides essential functionalities including Media Control Buttons, Display, Remote control and Pi Power Switch, all in one package. This convenience give you a true consumer electronics experience, while keeping the full customization and flexibility of Raspberry Pi.

NanoSound was successfully funded via kickstarter and delivered in October 2017.

An Speaker & Headphone Amp add-on is also available.

For more info, visit here

Just wanted to say thank you for the great email support that NanoMesher has given during my installation process. The DAC is up and running with very smooth sounds.

My NanoSound DAC was from the first batch of its production. While the installation was rather straightforward (but not without hiccups), I am please with the result. Thought that I should document a few pointers I was given here:

I found the following page very useful on the hardware installation (particularly, for someone who intents to use a Linear PSU for the DAC independently) as I do:

I first installed the NanoSound plug-in (as in the Software Installation support page) on Volumio 2.246. It ran as expected. However, after I had upgraded to Volumio 2.285, music stopped playing. The Mixer in Volumio UI also acted up. After a couple of emails back and forth with the customer support from NanoMesher who suggested the following changes, the NanoSound DAC has started to sing again:

A quote from one of the NanoMesher emails to change the NanoSound card from card 0 (as in 2.2.46) to card 1 (as in 2.285):

Edit /boot/config.txt, remove or comment the line


then edit /etc/asound.conf

pcm.!default {
type hw card 0
} ctl.!default {
type hw card 0

Then do a reboot.

I hope NanoMesher will update it’s plug-in to take care of this issue soon.

The LED displays works for my own music files, but not for Spotify. Not sure if any future plug-in upgrade would take care of it as well.

Note: The volume from the 3.5 mm jack on board of the NanoSound DAC is just enough for 32-ohm headphones (and is on the weak side). I have just placed an order for a NanaSound Amp^2 for my headphones with higher impedance.

All in all, I like the sound coming out of the NanoSound DAC. To my ears, the extreme top appears to be tamed and controlled, behaving a bit like good sounding tubes. The mid and low are quite pleasing for the kind of music I listen to (Jazz and Classical). With a Linear PSU feeding the DAC, the noise floor is very clean. I could hear a pin drop in the concert hall. And it’s that much of details that this DAC is rendering.

Thanks again,


Thanks John for the comment and glad that you liked the sound!

We have just figured out the problem after working with Volumio developers.

There are 2 issues found related to the upgrade:

  1. There is a bug in the volumio 2.285 wizard after the upgrade.

The workaround now is actually easier now , there is no need to edit any file.

The easier solution is either

  • skip wizard after upgrading to 2.285 or
  • if you accidentally ran the wizard, go to playback options, switch off i2c , reboot, switch on i2c again and resetup your DAC.
  1. LIRC setting in /boot/config.txt got removed during the upgrade

workaround is to add back below in /boot/config.txt


Volumio is working on bug #1 above and NanoSound is working on bug #2.

It should only take a few days to sort out. Thanks for raising these issues


I have an issue with music coming out of only one channel on Nanosound DAC.
Can someone advise.

Hi, have you tested both 3.5mm and RCA out? Is it the same?

Yes it is the same on both outputs.

We will contact you separately about this issue for diagnosis. thanks very much.

Just upgraded to 2.295 via Volumio’s web UI. No issues at all. NanoSound is running once I have the correct DAC selected. Thanks for fixing the bugs.


Thanks for letting us know John! Glad it’s all working now :smiley:


I have my new system of DAC + the AMP^2. The DAC runs fine if I run the output though an external amp. However if I plug my Bowers & Wilkins P5 into the Amp^2, the sound is terribly distorted at 60% volume and not especially loud (i.e. only a little louder than if I plug into the jack on the DAC - and its sound doesn’t distort at even at 100% volume). Any idea why the AMP seems to be so underpowered?

I have a different experience with the NanoSound DAC + Amp^2. The headphone output of the DAC alone is weak. When I pushed it to 100%, distortion is there in the low frequencies. At 90% volume and below, there is a slight high frequency roll-off. So, I was not thrilled by the performance of the NanoSound DAC as a headphone amp.

After a little wait for the Amp^2 to arrive, the new headphone jack from the Amp^2 works fine and get loud on my Grado SR325e headphone (with G Cushion that required louder volume). I only need 40-50% for normal listening. Please note that I am using two 2.5A power supply units to feed the DAC (linear) and RPi ($10) separately. The top and bottom frequencies come back strong with no distortion. But, still a tiny top roll-off. From a form factor point of view, it’s a good design to fit everything in a tiny 3D printed case. I can see a good use case for a small room (e.g., home office), room where only need lower power speakers (e.g., dining room), or embedding the NanoSound in a pair of DYI speakers for a good clean look. With Volumio multiple room control, I have two of this setup around the house to supplement my main system all working with a NAS. However, the price of a RPi + DAC + Amp^2, then add a pair of small speakers is not too far off from a Sonos 1. Had I gone down the Sonos route, I would have missed out a lot of fun from building the NanoSound system.

Just a few words on the assembly of Amp^2. The plastic screws and bolts came in the package are not sufficient. I have to get another bolt and a few extra washers to keep everything tight when attaching the Amp^2 to the DAC.


Hi John,

Thanks for your comment and support. The use case you described it exactly what we are targeting.

Regarding the assembly of Amp^2, we are looking into improvements by adding an extra 1mm washer to have an exact tight fit.




As John experienced, there should be absolutely no distortion from the headphone amp even at 60-70% level, which is already a very loud level.

Couple of suggestions:

  • Try changing the power supply / microUSB cable? You will need a good power supply/cable outputing “real” 2A or above.
  • Do you get the same result from other headphones?
  • Do you also get distortions using speaker output?
  • Make sure AMP^2 us well attached to the DAC, like below pic.

If problem persists, please drop an email to and we can help you there.




I´ve received yesterday my Nanosound board and the Amp^2,
So far I followed the “Help Test” and did a vanilla install of Volumio with the Nanosound 1.3.1, 1st. Method.
Just to be fair I only installed the Spotify plugin and also the Nanosound plugin reading carefully all instructions. I didn´t want to mess with programming without knowing exactly what I´m doing.
I don´t know what I´m supposed to read on Nanosound board but the only text I read is “NanoSound v 1.3.1”.
I think I ought to read some more output other than firmware number as shown in several photos we can see on internet.
The only button who´s working is the on/off button.
I think that I´m missing some instructions but didn´t find any.
Can someone clarify me where should I browse?

PS: Never mind, forgot to enable the plugin… And. because of that I´ll leave this post here so everybody will be aware of this. Enable the plugin, do not forget! :open_mouth:

I am experiencing an issue with my nanosound where the OLED display gets stuck displaying the last song of the queue. It always happens at the end of the queue and once it gets stuck it doesn’t show any new track information. The only way to restart the display is to restart the OLED daemon by disabling the Nanosound plugin and re-enabling it.


I just installed the “Nanosound pro”

Test environment:

Volumio v2.31 (fresh install on brandnew Sandisk Ultra 16GB SDcard)
Raspberry PI3 (passive cooled)
Nanosound pro
2 x Meanwell 5V/3A switching power supplies (because the PI isn’t supplied by my Nanosound i need a second)
1 x DIY 5V/2A Linear power supply for the DAC (Talema torroid, fast rectifier, LT1083, Nichicon… and filters)

First impression

At my first impression i haven’t been very glad with the condition the device has been shipped out. (Package not damaged in
any kind).
Many soldering points are corrected by hand soldering and flux is not washed off - but the worst is one of the RCA jacks is
soldered totally out of angle… and cold soldered… the other one is only slightly out of angle
and… cold soldered :blush:
1 plastic screw was missing in the package…

start up:
The PI is not supplied with power… In the current version of the Nanomasher support instructions is written: “In
both cases, you do not need to plug in to the microUSB port in the Raspberry Pi. The DAC powers the Pi as well.”

Connected to an extra PSU for the PI - now it is booting up.
Configured I2S to “Hifiberry +”
Installed Nanosound plugin - display is coming up :smiley: - But in the plugin settings there is nothing to configure - it only does show “Example Plugin Configuration”. Did there something go wrong ?

If the undocumented (didn’t find it) button without a sign is pressed the “tone” logo in the display disappears, what makes
me think it should be a “mute” button - but nothing is muted… Same button on the remote control does not even let the
“tone” logo on the display disappear.

I hope there will be updates of the plugin… My greatest hope has been to be able to set my favorite web radio station to start listening if i press the button without a sign (thought this one could be free programmable in the plugin settings).

The sound is very good as expected from a PCM5122 with good LDO.

@Nanomesher: Can you please help with configuring the non working Mute button ? (Ideally to work as “favorite radio station” button).


Hi gtang,

Once you reached end of queue, if you have not enabled repeat in volumio, it should just stop. Pressing play or selected another song is queue should start the playback again and the screen should display.

If you dont see above working, can you please let us know a little more details?

What kind of media does your queue contains? like what of files / streams?
We will try to reproduce the issue.


@gtang, we are sorry about the RCA jack and cold soldering. This is the first batch right after kickstarter :neutral_face: , there should be no impact on audio quality as you have experienced. We have since reflected this to our manufacturer and Quality control team, and we have seen big improvements in subsequent batches.

The button without a sign is for switching the Amp^2 addon as documented here -

As for software, We are working for major software improvements and have sent an update on this -

Finally, thank you for your support and comments on NanoSound, we will keep improving!

@ nanomesher,

Sounds good, i’m looking forward to it.

I will fix the RCA and other solder points myself, no big issue… Hope subsequent batches will look better.

The only thing i’am still a bit sad about is that i have to connect 2 power supplies. I cannot test for the next 2 days as i’m not at home but will again check if the power button works this way… will report next monday.

  • Josef

I have the Nanosound Basic DAC and Amp and these are working well. I would like to add the OLED display. The website mentions this needs to be soldered on - do you have any more instructions/pictures? Thanks