Nanosound DAC 2 no sound

I just received my Nanosound DAC 2 pro, which I ordered here. The display is working correctly but I’m not getting any sound.
I already tried this: turn I2S off, reboot using the button on the Nanosound, turn I2S on > reboot again.
My /var/log/mpd.log is not showing any errors and I can see my DAC when I do “aplay -l”.
I’m on Volumio v 2.729 and Nanosound plugin v 1.8.4 using a Raspberry Pi 3b+.

Any ideas what else I can try to get the sound working?


I just got mine too, and first boot I got the same thing. I also had display trouble. Rebooted/re-flashed many times, sound eventually worked but not display. Emailed support, and dave from nanomesher suggested the problem was the gpio extender. I removed the extender, and plugged the nanosound right onto the pi header, and this fixed all my issues. According to Dave, sometimes the pins don’t sit right in the extender. He suggested rotating it 180 degrees, or just re-seating, but I prefer the lower profile without the extender, so I’m leaving it like that.

Thanks codebreaker to help explain, we are going to check all the extender before shipping.

two more extra to check:

  • when booting, the green should light turn on for around 10seconds and then off after the system is up.
  • the green light should be on during audio playback, turned off during pause

Thanks for your replies.
I tried your suggestion, but it actually made it worse. The screen is still working though, but Volumio doesn’t recognize the DAC anymore.
It used to show up in the “aplay -l” command but after I tried it without the extender it doesn’t show up anymore.
Also, on the DAC itself there’s only a red LED on, no green one.

What else can I check?

root@volumio:/home/volumio# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 7/7 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1] Subdevices: 1/1 Subdevice #0: subdevice #0

This issue has been resolved offline. It turns out the Pi 3 had an issue with i2s and that’s why audio did not work.

Testing on another Pi have confirmed working.

Issue can be closed.

After using the Pi4 everything worked like it should. Thanks nanomesher for the support.